Error Message: HPW3ST1.EXE Caused a General Protection Fault... (180178)



The information in this article applies to:

  • Microsoft Internet Explorer 4.01 for Windows 95
  • Microsoft Internet Explorer 4.0 for Windows 95

This article was previously published under Q180178

SYMPTOMS

When you attempt to install the Hewlett-Packard (HP) DeskJet 1000C printer driver from the HP Starter CD-ROM, you may receive the following error message:
HPW3ST1.EXE caused a General Protection Fault (GPF) in module HPW3ST1.EXE
When you attempt to install the HP DeskJet 1000C printer driver from the HP printer driver disks, you may receive the following error message:
The Setup Wizard is unable to create the Program Groups or Icons.

CAUSE

This behavior can occur if you attempt to install the HP DeskJet 1000C printer driver on a Windows 95-based computer with Internet Explorer and the Windows Desktop Update component installed.

RESOLUTION

To work around this behavior, uninstall the Windows Desktop Update component, uninstall the HP DeskJet 1000C printer driver, and then reinstall the printer driver. To do so, use the following steps:
  1. Uninstall the Windows Desktop Update component. For information about how to uninstall the Windows Desktop Update component, see the following article in the Microsoft Knowledge Base:

    165695 How to Add or Remove Windows Desktop Update

  2. Uninstall the HP DeskJet 1000C printer driver. For information about how to uninstall the HP DeskJet 1000C printer driver, consult the documentation included with your printer, or contact Hewlett-Packard technical support.
  3. Reinstall the HP DeskJet 1000C printer driver. For information about how to reinstall the HP DeskJet 1000C printer driver, consult the documentation included with your printer, or contact Hewlett-Packard technical support.
NOTE: You can reinstall the Windows Desktop Update component after you install the HP DeskJet 1000C printer driver.

STATUS

The third-party product discussed in this article is manufactured by a vendor independent of Microsoft; we make no warranty, implied or otherwise, regarding this product's performance or reliability.

Modification Type:MajorLast Reviewed:11/5/2003
Keywords:kb3rdparty kbenv kbprb KB180178