SYMPTOMS
When you try to download statement information from your financial institution or from your brokerage house, you may receive an error message that is similar to one of the following:
There was a problem with the data received from
your financial institution. If this problem persists, call the Customer Support
number for your financial institution, listed on the Contact Information tab in
the Online Banking area.
Your last call encountered an error.
Or, if you try to import an Active
Statement file that has an OFX extension, you may receive the following error
message:
The file 'path\file name.ofx'
is not recognized by Money as an Active Statement file. No information has been
added to your Money file.
CAUSE
This problem may occur if the *.ofx file that you are
downloading or the response file that was sent for your statement request is not
correctly formatted according to the Open Financial Exchange (OFX) standards
that Microsoft Money expects.
A specific error code in the ofx/response file may also identify the problem.
This is a number following
CODE that is eight to 10 lines under the header in the OFX file or statement response.
Look up the error code number in the "Microsoft Money OFX Error Messages" document. To download this document, visit the following Microsoft Web site:
This issue can also be caused by an incorrect account number or a problem with the current set up of your online services.
The following causes for these error messages are listed in the order of frequency:
- Not a valid data file according to OFX standard:
contains invalid tags, or is missing required components.
- Incorrect formatting of the data in the file: invalid
length, content, or signs.
- Invalid Header in the file.
- Missing echo of a CLTCOOKIE request in the response
file.
- Missing response for a request sent.
RESOLUTION
To resolve this issue, try to connect again, and then force Money to save log files. Once you have collected the log file, you can review it for specific error codes and troubleshoot them accordingly. If there are no error codes or you cannot resolve the issue, you may need to contact your financial institution so that they can resolve the formatting error.
Note The financial institution that creates the response files and Active Statement files is responsible for formatting the files correctly.
Capture the Log files from the connection between Money and your financial institution
For more information about how to capture log files, click the following article number to view the article in the Microsoft Knowledge Base:
911941
How to capture an OFX log file in Money
Note After you capture the log files, it is advised that you contact your financial institution to walk through the analyzing of the files. If you would like to analyze the files on your own, please proceed with the following steps to determine what is causing the error.
Analyze the data file
Microsoft has created tools to enable our financial institution partners to verify the formatting of files that are sent to Money users.
http://www.microsoft.com/money/fi/tools.mspx The following tools are available from the Microsoft Partner support site:
- Ofxanlyz.exe
Use this to verify that all the content of
the OFX file is correct.
Use Ofxanlyz.exe
To verify that the contents of the response file are correctly
formatted, each response is the correct length, and each response has the
correct sign for tag values, follow these steps:
- The Ofxanlyz.exe tool analyzes files that are OFX type. Locate the <bankname>.ofxrq.txt and the ofxrs.txt log files you saved above.
- Open the Ofxanlyz.exe file.
- Click Browse, and then open the <bankname>Ofcrs.txt file.
- Click Analyze to parse and to verify the contents of the
file.
- Note any errors that the tool reports and contact your financial institution with this information..
If there are no error messages noted, please proceed with the following step:
Verify the header
To verify that the header of the OFX response file contains the
required components, follow these steps:
- Open the file name.OFXrs.txt file in Microsoft WordPad to view the file.
Note WordPad lets you to view the file in an easier format than
Notepad. To start WordPad, click Start, point to Programs, point to Accessories,
and then click WordPad. - Verify that the file contains the following required
components and is followed by a blank line.
OFXHEADER:100
DATA:OFXSGML
VERSION:
SECURITY:
ENCODING:
CHARSET:
COMPRESSION:
OLDFILEUID:<number/letter combination>
NEWFILEUID:<number/letter combination>
Note The OLDFILEUID and the NEWFILEUID tags can vary in content.
Check for missing cookie
Every Cookie in an OFX request file must have an answering Cookie
in the response file. To see whether a missing Cookie is the cause of the error,
follow these steps.
- Open both the <bankname>Ofxrq.txt file and the <bankname>Ofxrs.txt in
WordPad.
- View them side by side.
- Verify that every Cookie in the <bankname>Ofxrq.txt file has a
corresponding Cookie in the <bankname>Ofxrs.txt file.
If you are missing any cookies, please contact your financial institution with this information. If all cookies are listed, please proceed with the next step.
Checking for Corresponding Responses
Every tag in a request file must receive a corresponding
response, even if the response is empty. To verify that every request has a
response, follow these steps:
- Open both the <bankname>Ofxrq.txt file and the <bankname>Ofxrs.txt in
WordPad.
- View them side by side.
- Look through both files and confirm that every tag
request in the <bankname>Ofxrq.txt file has a corresponding response in the <bankname>Ofxrs.txt
file.
If you determine that your ofx log file is missing a tag in either the request (ofxrq.txt) file or the response (ofxrs.txt) file please contact your financial institution with this information. If the tags in your file all appear to have a valid request and response, please contact Microsoft Customer Support to further troubleshoot your issue.
If you and your financial institution determine that this issue did not occur because of a formatting error, try to disable and then re-enable online services for this financial institution.
For more information about how to disable and enable online accounts, click the following article number to view the article in the Microsoft Knowledge Base:
175728
How to disable and enable your Online Accounts in Money