Setup Error: Rsaenh.dll is Missing on SBS International Version (179728)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.0

This article was previously published under Q179728

SYMPTOMS

During setup of the International version of Microsoft BackOffice Small Business Server version 4.0, you may receive an error message telling you that Rsaenh.dll is missing. This may also occur with versions of SBS on MSDN or NFR CDs.

CAUSE

The file Txtsetup.sif has an incorrect reference to the file Rsaenh.dll. The file Rsaenh.dll is a file that ships with the 128-bit version of BackOffice Small Business Server. However, the international version of BackOffice Small Business Server is only 40-bit, thus the file Rsaenh.dll is not located on either CD.

RESOLUTION

Create a new set of boot disks from the CD and run setup again. A new set of CDs is not required. Perform the steps below to complete the installation of the Small Business Server.
  1. Insert the CD labeled Disk 1 in to a PC running Windows 95 or Windows NT.
  2. From the Desktop, click the Start button, and then click Run.
  3. Type the following line

    Windows NT:

    <drive:>\i386\winnt32.exe /ox

    Windows 95/98:

    <drive:>\i386\winnt.exe /ox

    where <drive:> is the drive letter of the CD-ROM. This will create three new boot disks for setting up BackOffice Small Business Server.
  4. After the three new boot disks have been created, copy Winnt.sif from the Support directory on the CD to the boot disk 2 that was just created.
  5. Run Setup again, this time using the new boot disk.

STATUS

This problem has been corrected. Manufacturing has updated the CDs with the corrected Txtsetup.sif file.

Modification Type:MajorLast Reviewed:10/13/2003
Keywords:kbprb kbsetup KB179728