Unable to Install Microsoft TCP/IP (179705)



The information in this article applies to:

  • Microsoft Windows 95
  • Microsoft Windows 95 OEM Service Release 1
  • Microsoft Windows 95 OEM Service Release 2
  • Microsoft Windows 95 OEM Service Release 2.1

This article was previously published under Q179705

SYMPTOMS

When you use the Network tool in Control Panel to install Microsoft Transmission Control Protocol/Internet Protocol (TCP/IP), you may be able to select Microsoft TCP/IP from the list of available protocols, but it may not appear in the list of installed components.

CAUSE

This behavior can occur if the Mstcp.dll file located in the Windows\System folder is missing or damaged.

RESOLUTION

To resolve this issue, follow these steps:
  1. Rename the Mstcp.dll file (if it exists). To do so, follow these steps:

    1. Click Start, point to Find, and then click Files Or Folders.
    2. In the Named box, type mstcp.dll, and then click Find Now.
    3. If the Mstcp.dll file is found, right-click it, and then click Rename. If the Mstcp.dll file is not found, skip to step E.
    4. Type a new name for the Mstcp.dll file (such as Mstcp.xxx), and then press ENTER.
    5. Close the Find window.
  2. Extract a new copy of the Mstcp.dll file from your original Windows 95 disks or CD-ROM to the Windows\System folder. The Mstcp.dll file is located in the following locations:

    • The Precopy1.cab cabinet file on the Windows 95 and Windows 95 OEM Service Release 2 (OSR2) CD-ROM.
    • The Precopy1.cab cabinet file on disk 1 of the original Windows 95 DMF floppy disks.
    • The Precopy2.cab cabinet file on disk 2 of the original Windows 95 non-DMF floppy disks.
    For information about using the Extract tool, please see the following article in the Microsoft Knowledge Base:

    129605 How to Extract Original Compressed Windows Files

  3. Restart your computer.

Modification Type:MajorLast Reviewed:3/5/2002
Keywords:kbnetwork kbprb KB179705