CRS: CRS Automatic Replication Ends with Error MessageId=15130 (179275)



The information in this article applies to:

  • Microsoft Commercial Internet System 1.0
  • Microsoft Content Replication System
  • Microsoft Site Server 2.0

This article was previously published under Q179275

SYMPTOMS

Automatic replication by the Microsoft Content Replication System (CRS) appears to stop and does not replicate any files even after the files are changed or touched.

CRS attempts to replicate the file five times, waiting for 30 seconds between each retry. After five attempts, CRS ends the replication with the following error message in the Windows NT Application log:
MessageId=15130 CRS was unable to replicate the file %1 because it was inaccessible.
%1 includes an (rc=xx) code that is the Windows NT helpmsg number that denotes why the file was inaccessible. To determine the condition of the file that caused the error, from a command prompt enter:

net helpmsg xx

where "xx" is the code from the error message.

CAUSE

This can be caused by one or more corrupt files. CRS may have been notified that the file was changed, but corruption in the file may disable CRS from opening it. CRS interprets its inability to open the file as the file being locked. The normal behavior of CRS for addressing locked files in automatic mode is to wait until the lock is cleared. Because of this, CRS continues to wait on the corrupted file.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Commercial Internet System version 1.0 and Microsoft Site Server version 2.0.

This problem has been corrected in the latest U.S. Service Pack for Site Server 2.0 Service Pack 1. For information on obtaining the Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

S E R V P A C K


Modification Type:MajorLast Reviewed:11/17/2003
Keywords:kbbug kbfix kbQFE KB179275