XFOR: Exchange cc:Mail Connector Causes NFT Error on Clandata (179072)
The information in this article applies to:
- Microsoft Exchange Server 5.0
- Microsoft Exchange Server 5.5
This article was previously published under Q179072 SYMPTOMS
The Microsoft Exchange Connector for Lotus cc:Mail may stop. The cc:Mail
executable Import.exe produces the log file NFTerror.log in the cc:Mail
post office directory. The Windows NT Application log may include multiple
occurrences of the following events:
Event ID: 59
Lotus cc:Mail IMPORT from file *.ccm returned result code 1. Program
did not complete successfully.
Event ID: 62
MSExchangeCCMC
Lotus cc:Mail IMPORT from file %1 returned result code 4. The Lotus
cc:Mail post office is locked by another process. %2
Event ID: 71
MSExchangeCCMC
Lotus cc:Mail EXPORT to file %1 returned result code 4. The Lotus
cc:Mail Post Office is locked by another process %2
Event ID: 59
Lotus cc:Mail IMPORT from file *.ccm returned result code 1. Program did
not complete successfully.
Event ID: 68
Lotus cc:Mail EXPORT to file msg4987.ccm returned result code 1. Could
not access the Lotus cc:Mail Post Office.
CAUSE
Microsoft Exchange Connector for Lotus cc:Mail is designed to redirect the
Import/Export console messages to temporary files located in the
Exchsrvr\Ccmcdata directory. However, the file handles used to control
these temporary files may not be generated correctly. When a file handle
for a temporary file incorrectly matches a file handle used for a message
content, the Microsoft Exchange Connector for Lotus cc:Mail writes the
screen output to the header of that message. This writing causes Clandata
corruption.
WORKAROUND
If the post office is a hub post office (without any users), then perform
the following steps to restore message flow quickly:
- Restore the post office from a current backup, before the corruption.
- If there is no reliable backup, then install a new post office. Be
careful to match the naming and routing configuration of the production
post office.
If the post office has users, then follow these steps:
- Inform the users that there may be a long period of message outage.
- Install a new post office and reconfigure the routing.
- Move each user from the corrupt post office to the new post office.
- After the new post office is ready, review the cc:Mail temporary
directories for any corrupt messages.
- Move the corrupt post office outside its original directory.
- Move the new post office to the location of the production post office.
- Restart the Microsoft Exchange Connector for Lotus cc:Mail.
STATUS
Microsoft has confirmed this to be a problem in Microsoft Exchange Server
version 5.0. This problem has been corrected in the latest U.S. Service
Pack for Microsoft Exchange Server version 5.0. For information on
obtaining the Service Pack, query on the following word in the Microsoft
Knowledge Base (without the spaces):
Microsoft has confirmed this to be a problem in Microsoft Exchange Server
version 5.5. This problem has been corrected in the latest U.S. Service
Pack for Microsoft Exchange Server version 5.5. For information on
obtaining the Service Pack, query on the following word in the Microsoft
Knowledge Base (without the spaces):
Modification Type: | Major | Last Reviewed: | 4/7/2006 |
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Keywords: | kbQFE KBHotfixServer kbbug kbfix kbusage KB179072 |
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