Error Message When You Click Search in Internet Explorer (178141)



The information in this article applies to:

  • Microsoft Internet Explorer 1.0 for Windows 95
  • Microsoft Internet Explorer 2.0 for Windows 95
  • Microsoft Internet Explorer 3.0 for Windows 95
  • Microsoft Internet Explorer 3.01 for Windows 95
  • Microsoft Internet Explorer 3.02 for Windows 95
  • Microsoft Internet Explorer 4.0 for Windows 95
  • Microsoft Internet Explorer 4.01 for Windows 95
  • Microsoft Internet Explorer 5.0 for Windows 95
  • Microsoft Internet Explorer 5.01 for Windows 95
  • Microsoft Internet Explorer 5.5 for Windows 95
  • Microsoft Internet Explorer 3.x for Windows 95
  • Microsoft Internet Explorer 4.x for Windows 95
  • Microsoft Internet Explorer 2.0 for Windows NT 4.0
  • Microsoft Internet Explorer 3.0 for Windows NT 4.0
  • Microsoft Internet Explorer 3.01 for Windows NT 4.0
  • Microsoft Internet Explorer 3.02 for Windows NT 4.0
  • Microsoft Internet Explorer 4.0 for Windows NT 4.0
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0
  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 5.01 for Windows NT 4.0
  • Microsoft Internet Explorer 5.5 for Windows NT 4.0

This article was previously published under Q178141

SYMPTOMS

When you click Search, you may receive the following error message:
Internet Explorer Script Error

An error has occurred in the script on this page.

Line: 159
Char: 3
Error: 'gEngineList[...].dom' is not an object
Code: 0

Do you want to continue running scripts on this page?

CAUSE

This behavior can occur for either of the following reasons:

  • You have disabled all cookie use and you are using the Microsoft Search Settings control.
  • There is a damaged cookie in the Cookies folder.

RESOLUTION

To resolve this behavior, use the appropriate method:

Configure Internet Explorer to Accept Cookies

To configure Internet Explorer to accept cookies, follow these steps:
  1. Click Start, point to Settings, click Control Panel, and then double- click Internet.
  2. Click the Advanced tab.
  3. Under Cookies, click one of the following options:

    • Always Accept Cookies
    • Prompt Before Accepting Cookies
    NOTE: If you click Prompt Before Accepting Cookies, you receive a Security alert before any cookies are downloaded to your computer.
  4. Click OK.

Remove the Microsoft Search Settings Control

To remove the Microsoft Search Settings control, follow these steps:
  1. Click Start, point to Settings, click Control Panel, and then double- click Internet.
  2. On the General tab, click Settings.
  3. Click View Objects, right-click Microsoft Search Settings Control, and then click Remove.
  4. Close the Downloaded Program Files folder, click OK, and then click OK.
  5. Start Internet Explorer, and click No if you receive the following Security warning:

    Do you want to install and run Internet Explorer Search Enhancements?

    NOTE: If you receive the Security warning, do not complete the remaining steps. If you do not receive the Security Warning, complete the remaining steps.
  6. On the View menu, click Internet Options, and then click the Security tab.
  7. Click Reset, click OK, quit Internet Explorer, and then repeat steps 1-4.

Remove Damaged Cookies

  1. Quit Internet Explorer (if it is running).
  2. Click Start, point to Programs, and then click Windows Explorer or Windows NT Explorer.
  3. Double-click the drive on which Windows is installed (usually drive C).
  4. Double-click the Windows folder.
  5. Double-click the Cookies folder.
  6. Delete the cookie from http://home.microsoft.com.
  7. Quit Windows Explorer or Windows NT Explorer.

MORE INFORMATION

For additional information about cookies, click the article number below to view the article in the Microsoft Knowledge Base:

154360 Security Alert for Cookies in Internet Explorer and Outlook Express


Modification Type:MajorLast Reviewed:12/16/2003
Keywords:kbenv kberrmsg KB178141