Not Prompted to Specify Download Folder for File (177976)



The information in this article applies to:

  • Microsoft Internet Explorer 1.0 for Windows 95
  • Microsoft Internet Explorer 2.0 for Windows 95
  • Microsoft Internet Explorer 3.0 for Windows 95
  • Microsoft Internet Explorer 3.01 for Windows 95
  • Microsoft Internet Explorer 3.02 for Windows 95
  • Microsoft Internet Explorer 4.0 for Windows 95
  • Microsoft Internet Explorer 4.01 for Windows 95
  • Microsoft Internet Explorer 5.0 for Windows 95
  • Microsoft Internet Explorer 5.01 for Windows 95
  • Microsoft Internet Explorer 5.5 for Windows 95
  • Microsoft Internet Explorer 3.x for Windows 95
  • Microsoft Internet Explorer 4.x for Windows 95
  • Microsoft Internet Explorer 4.0 for Windows 98
  • Microsoft Internet Explorer 4.01 for Windows 98
  • Microsoft Internet Explorer 5.0 for Windows 98
  • Microsoft Internet Explorer 5.01 for Windows 98
  • Microsoft Internet Explorer 2.0 for Windows NT 4.0
  • Microsoft Internet Explorer 3.0 for Windows NT 4.0
  • Microsoft Internet Explorer 3.01 for Windows NT 4.0
  • Microsoft Internet Explorer 3.02 for Windows NT 4.0
  • Microsoft Internet Explorer 4.0 for Windows NT 4.0
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0
  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 5.01 for Windows NT 4.0
  • Microsoft Internet Explorer 5.5 for Windows NT 4.0

This article was previously published under Q177976

SYMPTOMS

When you download a file from the Internet, you may not be prompted for the location in which to save the file that you are downloading. Instead, the file may be opened.

CAUSE

This behavior can occur if you clear the Always ask before opening this type of file check box when you download a file. If you do this, files of this type are automatically placed in the Temporary Internet Files folder and opened by the program that is associated with the file type.

RESOLUTION

If you want to be prompted for a download location for the file type, follow these steps:
  1. Double-click My Computer.
  2. On the View menu, click Folder Options.
  3. On the File Types tab, click the appropriate file type in the Registered File Types box.
  4. Click Edit.
  5. Click to select the Confirm Open After Download check box.
  6. Click OK, and then click OK.

MORE INFORMATION

When you first click a link to download a file, the File Download dialog box appears. You have the following options:
  • Open this file from its current location
  • Save this file to disk
  • Always ask before opening this type of file
If you clear the Always ask before opening this type of file check box, you indicate that this type of file should always be opened with the associated program. The file is then downloaded to your Temporary Internet Files folder and opened.

If the Always ask before opening this type of file check box is unavailable, there is no program associated with the file type. For example, if you download a file with a .zip extension, the check box is unavailable unless you have installed a program that can open .zip files.

For additional information about downloading .exe files with Internet Explorer, click the article number below to view the article in the Microsoft Knowledge Base:

140991 Internet Explorer Opens .exe Files Instead of Downloading Them

For additional information about a tool to automate this process for all Microsoft Office file types, click the article number below to view the article in the Microsoft Knowledge Base:

238918 Availability of Microsoft Office Document Open Confirmation Tool


Modification Type:MajorLast Reviewed:12/5/2003
Keywords:kbenv kbprb kbui KB177976