BUG: Anonymous Logon Causes Spooler to Hang During Logoff (177630)



The information in this article applies to:

  • Collaboration Data Objects (CDO) 1.1
  • Collaboration Data Objects (CDO) 1.2
  • Collaboration Data Objects (CDO) 1.21
  • Microsoft Access 97

This article was previously published under Q177630

SYMPTOMS

After you create an anonymous session to the Exchange Server, the system stops responding (hangs) when you attempt to log off.

CAUSE

Logging on anonymously should not launch the Spooler, but by default the Spooler is started. Once started, the system hangs when it is issued a LogOffSpooler command.

RESOLUTION

When calling the Logon method of the Session object, set the NoMail parameter to True to prevent the Spooler from starting.

STATUS

Microsoft has confirmed this to be a bug in the Microsoft products listed at the beginning of this article. We are researching this bug and will post new information here in the Microsoft Knowledge Base as it becomes available.

MORE INFORMATION

Steps to Reproduce Behavior

  1. Copy and paste the following code into an Access form.

    NOTE: The underscore is used as a line-continuation character:
          Sub Session_Logon_Anon()
            Dim cServerDName, enterprise, site, server As String
            Dim objSession As Object
            Set objSession = CreateObject("MAPI.Session")
    
            If Not objSession Is Nothing Then
               MsgBox "CreateObject('MAPI.Session') Failed"
            Else
             'Modify the next 3 lines to properly define the enterprise,
             'site, and server for your system.
             enterprise = ""
             site = ""
             server = ""
             cServerDName = "/o=" & enterprise & "/ou=" & site & _
                    "/cn=Configuration/cn=Servers/cn=" & server
           objSession.Logon _
             Profileinfo:=cServerDName & vbLf & vbLf & "anon", _
             showDialog:=False
           End If
          End Sub
    					
  2. Place a breakpoint on the "End If" line.
  3. When you stop at the breakpoint, click Exit on the File menu.

Modification Type:MinorLast Reviewed:3/4/2004
Keywords:kbBug kbMsg kbnofix KB177630