Use LoadLibraryEx When Loading Printer Drivers (177445)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0

This article was previously published under Q177445

SYMPTOMS

In specific instances under Windows NT 4.0, certain Hewlett Packard printer drivers may display a pop-up message that indicates that the print driver is not installed when it has been installed.

CAUSE

Some of the Hewlett Packard printer driver files statically link to other printer driver files that are listed as dependent files. The Windows NT spooler uses a LoadLibrary function call not the LoadLibraryEx function call. This, in combination with Hewlett Packard's print driver directory not being in the path, causes the Hewlett Packard driver not to work.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

152734 How to Obtain the Latest Windows NT 4.0 Service Pack


STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbprint KB177445