Multiprocessor computer may stop responding (hang) because of Tcpip.sys (177245)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0

This article was previously published under Q177245

SYMPTOMS

A multiprocessor computer running Microsoft Windows NT version 4.0 may appear to stop responding (hang) when subjected to heavy TCP/IP stress. The system will continue to respond to PINGs, but higher level TCP/IP activity will be blocked. If other network protocols are installed, the system may continue to function normally except for activities that depend on TCP/IP.

CAUSE

For this problem to occur, a process must have an open handle to an address and an open handle to a connection and must try to close both simultaneously (as, for example, might happen at process termination). Under very specific and timing-dependent situations, Tcpip.sys can become deadlocked, blocking further work by the driver. When this happens, other parts of the system will typically continue running for a period of minutes or longer until higher level services that depend on Tcpip.sys also become blocked, waiting for the driver.

RESOLUTION

Windows NT 4.0

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows NT 4.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

152734 How to obtain the latest Windows NT 4.0 service pack

Windows NT Server 4.0, Terminal Server Edition

STATUS

Windows NT 4.0

Service pack information

This problem was first corrected in Microsoft Windows NT 4.0 Service Pack 5.Microsoft has confirmed that this is a problem in Windows NT 4.0. This problem was first corrected in Windows NT 4.0 Service Pack 4.

Windows NT Server 4.0, Terminal Server Edition

Microsoft has confirmed that this is a problem in Windows NT Server 4.0, Terminal Server Edition.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbnetwork KB177245