XADM: Errors Occur During Exchange Service Pack Upgrade (177221)
The information in this article applies to:
- Microsoft Exchange Server 4.0
- Microsoft Exchange Server 5.0
- Microsoft Exchange Server 5.5
This article was previously published under Q177221 SYMPTOMS
When you attempt to apply a service pack to a computer running Microsoft
Exchange Server, you may receive an error message during setup that says
some files are in use, even when no other applications are running. The
error message may be similar to the following:
Could not open the file named 'C:\EXCHSRVR\BIN\ADDRESS.DLL'. It is in use by another application.
CAUSE
The System Attendant is possibly running again. Part of the
update and setup process is to first stop all known Exchange related
services; this includes the System Attendant. However, if there is at least one server monitor running against the server, the System Attendant can be
restarted. This occurs even if:
- The system attendant is not set to be monitored.
- The server monitor is configured to take no action.
- You use ADMIN /T NR to suspend notifications and repairs.
WORKAROUND
To work around this issue, stop all server monitors that run against the
Exchange Server computer that is being upgraded.
MORE INFORMATION
Microsoft has confirmed this to be an issue in Microsoft Exchange Server
versions 4.0, 5.0, and 5.5. Microsoft is researching this issue and will post new information in the Microsoft Knowledge Base as it becomes
available.
| Modification Type: | Minor | Last Reviewed: | 4/28/2005 |
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| Keywords: | kbbug KB177221 |
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