PRB: Error Message: A Device Attached to the System is Not Functioning (177115)



The information in this article applies to:

  • Microsoft Commerce Server 2.0

This article was previously published under Q177115

SYMPTOMS

You may receive the error message
A device attached to the system is not functioning
during Microsoft Commerce Server setup, or when you run the Store Foundation or the Starter Store Copy wizards.

CAUSE

The error occurs when you log the WWW Service to a SQL or an ODBC database, and select a user name that has a password. If the user name does not have a password, the error does not occur.

WORKAROUND

To work around the problem, use either of the following methods:
  • Before you run either setup or the wizards, make sure the Enable Logging check box in the Logging section of the WWW Service Properties dialog box is cleared or that the Log to File check box is selected.

    -or-
  • Create a login ID and user name in SQL Server that has no password. For security reasons, this user should have only INSERT permissions for the table to which you are logging.

Modification Type:MajorLast Reviewed:9/30/2003
Keywords:kberrmsg kbprb KB177115