BUG: Oleview Hangs with Incorrect Typelib Viewer Registration (176938)
The information in this article applies to:
- Microsoft OLE Libraries, when used with:
- Microsoft Platform Software Development Kit (SDK) 1.0
This article was previously published under Q176938 SYMPTOMS
When attempting to view a type library, Oleview appears to hang and does
not respond to user interaction. In addition, Task Manager shows that the
Oleview.exe and Rpcss.exe processes combined are taking up nearly 100% of
CPU time.
CAUSE
This problem is caused by an incorrect registration of the Iviewers.dll in-
process server. Iviewers.dll contains the type library interface viewer
object used by Oleview to parse the type library. The problem happens when
the InProcServer32 entry for this object (under HKCR\CLSID\{57EFBF49-4A8B-
11CE-870B-0800368D2302}) points to an incorrect path. This exposes a bug in
Oleview that causes it to try to load the viewer object in an infinite
loop.
RESOLUTION
To resolve this problem, re-register Iviewers.dll. This DLL is supplied
along with Oleview.exe as a part of either the platform SDK or the Visual
C++ compiler. Locate the DLL on the machine, and register its objects by
issuing the following command:
STATUS
Microsoft has confirmed this to be a bug in the Microsoft products listed
at the beginning of this article.
Modification Type: | Minor | Last Reviewed: | 7/11/2005 |
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Keywords: | kbBug KB176938 |
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