"Installation is incomplete" error message when you try to install Internet Explorer 4.0 on a Windows 95-based computer (176667)
The information in this article applies to:
- Microsoft Internet Explorer 4.0 for Windows 95
This article was previously published under Q176667 IMPORTANT This article contains information about editing the registry.
Before you edit the registry, you should first make a backup copy of the
registry files (System.dat and User.dat). Both are hidden files in the
Windows folder.
SYMPTOMS
When you install Internet Explorer on a Windows 95-based computer, you may receive an error message
that is similar to the following message:
Installation is Incomplete. The following Internet Explorer 4.0
components were not installed: [component or program name]
When you click OK, your computer restarts and Internet Explorer Setup
finishes. The component or program listed in the error message may appear
with Internet Explorer on the Start menu. You may also receive error
messages as you attempt to configure or use the component or program.
If you attempt to add an optional component after installing Internet
Explorer, you may receive an error message that is similar to the following
message:
Installation summary: [component or program name] - Error Installing
Component.
CAUSE
This behavior can occur if the following registry key exceeds 64K in size
or will exceed 64K after the installation of the program or component:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs
Windows 95 has registry keys that are limited to 64K in size. This
behavior can occur with any program that adds entries to this registry
location.
RESOLUTIONTo resolve this problem, obtain Internet Explorer 4.01. To do so, visit
the following Microsoft Web site:
WORKAROUND
To work around this behavior, reduce the number of entries in the registry
key. To do so, follow these steps: WARNING Using Registry Editor incorrectly can cause serious problems
that may require you to reinstall Windows 95. Microsoft cannot guarantee
that problems resulting from the incorrect use of Registry Editor can be
solved. Use Registry Editor at your own risk.
For information about how to edit the registry, view the Changing Keys and
Values online Help topic in Registry Editor (Regedit.exe). Note that you
should make a backup copy of the registry files (System.dat and User.dat)
before you edit the registry.
- Use Registry Editor to examine the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs
- Decide which programs you want to remove.
Note One way you can decide
which programs to remove is to scroll through the entries in the
SharedDlls key and note which program names are listed the largest
number of times. These programs have the most entries in the key, and
removing the programs reduces the size of the key.
- Quit Registry Editor, and then uninstall the programs whose entries you
want to remove from the registry key.
Note Do not delete entries in the registry key manually. Doing so may
cause other programs not to run correctly.
You can also work around this behavior by temporarily removing these
entries and then installing Outlook Express. To do so, follow these steps:
- Use Registry Editor to navigate to the registry key listed above.
- On the Registry menu, click Export Registry File.
- Type a name for the registry file, and then click Save. This creates a
file on the desktop.
- Click all the entries in the key, click Delete on the Edit menu, and
then quit Registry Editor.
- Click Start, point to Settings, click Control Panel, and then double-
click Add/Remove Programs.
- Click Microsoft Internet Explorer 4.0, and then click Add/Remove.
- Click "Add a component to Internet Explorer," and then click OK.
- If necessary, click Yes when you are prompted to connect to your
Internet service provider (ISP).
- Click Yes when you receive the following prompt:
Active Setup is about to determine what Internet components
are installed on your computer. Is this OK?
- Click the Microsoft Outlook Express check box to select it, and then
click Next.
- In the Please Select A Download Site box, click a site, and then click
Install Now.
- Click OK when you receive the message "Installation Summary: Microsoft
Outlook Express - Succeeded."
- Click Yes when you are prompted to restart your computer.
- On the Desktop, double click the registry file you created in step 3.
You may receive the following error message, and then click OK:
Cannot import C:\WINDOWS\DESKTOP\<shared.reg>: Error writing to the
registry
This error message typically occurs because not all the registry keys can
be imported.
Note You may receive error messages from programs that reference entries
in this key that were not imported.
| Modification Type: | Minor | Last Reviewed: | 11/15/2005 |
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| Keywords: | kbenv kberrmsg KB176667 |
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