Cannot Connect to Windows Using Windows CE Services (176047)



The information in this article applies to:

  • Microsoft Windows CE 3.0 Professional Edition for the Handheld PC
  • Microsoft Windows CE 2.0 for the Handheld PC
  • Microsoft Windows CE for the Palm-size PC, Versions 2.0
  • Microsoft Windows CE for the Handheld PC, Versions 1.0
  • the operating system: Microsoft Windows NT 4.0
  • Microsoft Windows CE Services 2.0
  • Microsoft Windows CE Services 2.1
  • Microsoft Windows CE Services 2.2
  • the operating system: Microsoft Windows 98
  • the operating system: Microsoft Windows 95

This article was previously published under Q176047

SYMPTOMS

When you use Microsoft Windows CE Services (or Microsoft H/PC Explorer for Windows CE version 1.0) in Windows NT, you may not be able to connect to a Handheld PC (H/PC). You may receive one of the following error messages on the H/PC:

Remote Service not started

Critical Services cannot be started
You may also receive the following error message on the desktop computer running Windows NT:
Remote Service Start failed

CAUSE

This behavior can occur if the Transport Control Protocol/Internet Protocol (TCP/IP) address of the H/PC is not in the Local Address Table (LAT) of the WinSock Proxy server.

RESOLUTION

To resolve this behavior, use the following steps:

  1. On the desktop computer, start Internet Service Manager (ISM).
  2. Configure WinSock Service.
  3. Go to Service, Local Address Table, and add the addresses of the H/PC's (by default 192.168.55.100 and 192.168.55.101).
  4. Stop and Restart the WWW and WinSock Service.
  5. Click Start, point to Settings, click Control Panel, and then double- click WSP Client. Click Update Now, and then click OK.
  6. Restart the client computer.
To work around this behavior, remove the WinSock Proxy Client from the desktop computer.

MORE INFORMATION

Mobile Devices communicates with the H/PC and P/PC using TCP. During Windows CE Services installation, the Microsoft Windows NT Remote Access Service (RAS) server or the Windows 95/98 Dial-Up Networking (DUN) support is installed and is assigned the static Internet Protocol (IP) address range of 192.168.55.100 to 192.168.55.102.

When the H/PC or P/PC is docked, it connects to the RAS server or DUN client and is assigned the IP address of 192.168.55.101. Thereafter, the H/PC or P/PC establishes a TCP connection to Mobile Devices for logon. ActiveSync then establishes a TCP connection to the H/PC or P/PC for the actual data transfer.

When the Winsock Proxy client is installed and the IP address range of 192.168.55.100 to 192.168.55.102 is not specified in the local LAT, Windows CE Services cannot establish the connection back to the H/PC or P/PC. Instead, it sets up a control channel connection to the Winsock Proxy server and tries to reach the H/PC or P/PC on the proxy server's external network. This WinSock Proxy behavior is by design.

To let ActiveSync communicate with the H/PC or P/PC using the local RAS server, just add the IP address range 192.168.55.100 to 192.168.55.102 to the local LAT on the client computer.

Creating a Client LAT File

When you run the client Setup program, a file named Msplat.txt is installed in the Mspclnt folder on the client computer. The Msplat.txt file contains the LAT, which defines the IP addresses of your internal network. To keep the LAT files current, the Msplat.txt file is regularly updated from the server. Each time a Winsock program on that client attempts to establish a connection to an IP address, the LAT is used to determine if the IP address is external or is on the internal network. If the address is internal, the connection is made directly. If the address is external, the connection is made using the Winsock Proxy service on Microsoft Proxy Server.

In some situations, the LAT table that is downloaded by the server may not completely define some addresses that a particular client needs to gain access to in the internal network. Because each client's Msplat.txt file is overwritten at regular intervals by a fresh version downloaded from the server, any changes you make at the client are lost each time the server updates the file.

To avoid this behavior, use a text editor to create a custom LAT file named Locallat.txt for the client, and place it in the client's Mspclnt folder. You can add additional IP address ranges that the client recognizes as part of the internal network. The client uses both the Msplat.txt and Locallat.txt files to determine which IP addresses are part of the internal network and which are on the Internet.

When you create the Locallat.txt file, type IP address pairs in the file. Each address pair defines either a range of IP addresses or a single IP address. The following example shows a Locallat.txt file that has two entries. The entries in the left column are an IP address range and the entries in the right column denote a single IP address.
+-------------------------------+
| 10.51.0.0     | 10.52.144.103 | 
+-------------------------------+
| 10.51.255.255 | 10.52.144.103 | 
+-------------------------------+
				
NOTE: The second entry is an IP address and not a subnet mask. For more information about the LAT, refer to "About the LAT" topic in the "Installing Server Software" section in Microsoft Proxy Server documentation.

Modification Type:MajorLast Reviewed:12/5/2003
Keywords:kbenv kbnetwork kbprb KB176047