OFF97 Err Msg: "Setup Cannot Register Docobj.dll..." (176022)



The information in this article applies to:

  • Microsoft Office 97 for Windows

This article was previously published under Q176022
IMPORTANT: This article contains information about editing the registry. Before you edit the registry, make sure you understand how to restore it if a problem occurs. For information about how to do this, view the "Restoring the Registry" Help topic in Regedit.exe or the "Restoring a Registry Key" Help topic in Regedt32.exe.

SYMPTOMS

When you run the Microsoft Office 97 Setup program, you may receive the following error message after you select the installation type:
Setup cannot register Docobj.dll in the system registry because an older
version is in use. Close all applications and try again.

CAUSE

This problem may occur if all of the following conditions are true:

  • You have installed Microsoft Office 7.0 on the computer.

    -and-
  • You have installed Internet Explorer 4.0 on the computer.

RESOLUTION

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

For information about how to edit the registry, view the "Changing Keys And Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete Information in the Registry" and "Edit Registry Data" Help topics in Regedt32.exe. Note that you should back up the registry before you edit it.

To work around this problem, follow these steps:

  1. On the Start menu, click Run. In the Open box, type "regedit" (without the quotation marks) and click OK.
  2. In the Registry window, click the plus sign (+) to the left of the following keys in the order listed:
          HKEY_LOCAL_MACHINE
          SOFTWARE
          Classes
          CLSID
          {b722bcc4-4e68-101b-a2bc-00aa00404770}
    						
    Then, click the InprocServer32 folder to open the following key:
          HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{b722bcc4-4e68-101b-a2bc-
          00aa00404770}\InprocServer32
    						
  3. On the Edit menu, click Delete, and then click Yes to delete the key.
  4. On the Registry menu, click Exit.
After you are finished, restart the computer. You can then install Microsoft Office 97 without receiving the error message.

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

Modification Type:MajorLast Reviewed:2/20/2004
Keywords:kbbug kberrmsg kbsetup KB176022