OFF97: Invalid Page Fault When Attempting to Use Internet Functionality (175976)



The information in this article applies to:

  • Microsoft Office 97 for Windows
  • Microsoft Excel 97 for Windows
  • Microsoft Word 97 for Windows
  • Microsoft PowerPoint 97 for Windows
  • Microsoft Access 97

This article was previously published under Q175976
WARNING:This information is preliminary and has not been confirmed or tested by Microsoft. Use only with discretion.

SYMPTOMS

When you attempt to use any of the Web features in the Microsoft Office programs listed at the beginning of this article, and Microsoft Internet Explorer is installed, you may receive an error message similar to one of the following
Program name caused an invalid page fault in module SHDOCVW.DLL at address 014f:71528dd.
Program name caused an invalid page fault in module GDI32.DLL at address 014f:bff349d9.
Program name caused an invalid page fault in module KERNEL32.DLL at address 014f:bff786a6.
Program name caused an invalid page fault in module MSO97.DLL at address 014f:30702681
where Program name is the name of the Microsoft Office program you are using.

CAUSE

This behavior may occur when one of the following conditions is true:
  • One or more cache files in the Temporary Internet Files folder are damaged.

  • The History folder or the cache folders used by Internet Explorer are damaged.

  • The index files used to track the contents of the History or cache folders are damaged.

RESOLUTION

To resolve this behavior, use one of the following methods.

Method 1: Delete and Re-register the Temporary Internet Files Folder

To delete and re-register the Temporary Internet Files folder, follow these steps:
  1. Click Start, point to Programs, and then click MS-DOS Prompt.
  2. Type the following line

    deltree "c:\windows\Temporary Internet Files"

    where windows is the folder where you installed Windows. Be sure to include the quotation marks. When you are prompted to confirm the deletion, press Y, and then press ENTER.
  3. Type exit, and then press ENTER.
  4. Click Start, and then click Run.
  5. In the Open box, type regsvr32 cachevu.dll, and then click OK.

    This step registers the deleted Temporary Internet Files folder again.

Method 2: Empty the Internet Explorer History and Cache Folders

To empty the History and cache folders used by Microsoft Internet Explorer, follow these steps:
  1. In Internet Explorer, click Options on the View menu.
  2. Click the Navigation tab, click Clear History under History, and then click Yes in the dialog box that appears.
  3. Click the Advanced tab, click Settings under Temporary Internet Files, click Empty Folder, and then click Yes in the dialog box that appears.

    After you perform this step, check to see whether the issue is resolved. If it has not been resolved, continue to step 4.
  4. Click Start, point to Settings, and then click Control Panel. In Control Panel, double-click the Add/Remove Programs icon.
  5. Click Internet Explorer 3.0 in the list of installed programs, and then click Add/Remove.
  6. After you remove Internet Explorer 3.0 or 3.01, restart the computer. When you see the "Starting Windows 95" message, press F8, and then click Command Prompt Only on the Startup menu.
  7. Type the following commands, pressing ENTER after each command.

    cd \windows
    smartdrv
    deltree "Temporary Internet Files"
    deltree history
    cd system
    ren mshtml.dll mshtml.old
    ren shdocvw.dll shdocvw.old
    ren inetcfg.dll inetcfg.old
    ren actxprxy.dll actxprxy.old
    ren wininet.dll wininet.old
    ren cachevu.dll cachevu.old
    ren inetcpl.cpl inetcpl.old
    ren shlwapi.dll shlwapi.old
    ren url.dll url.old
    ren urlmon.dll urlmon.old
    ren wsock32n.dll wsock32n.old

    NOTE: When you press ENTER after typing each of the following deltree commands, you should be prompted to confirm that you want to delete the folder. If you are not prompted, you may have typed the command incorrectly.

  8. Press CTRL+ALT+DELETE to restart your computer and restart Windows in normal mode.

MORE INFORMATION

You may see these error messages when you attempt to use the Web toolbar, insert hyperlinks in a document, open or link to Web files, or click hyperlinks in a document.

Modification Type:MajorLast Reviewed:5/23/2003
Keywords:kberrmsg kbprb KB175976