Dr. Watson Causing Fault in USER32 (175875)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows NT Server 4.0

This article was previously published under Q175875

SYMPTOMS

When a program is running on a computer running Windows NT Server, it may at times raise an exception for any of a number of reasons. Ordinarily, an exception like this calls the Dr. Watson system utility which then captures the exception, writing out a Dr. Watson log and a user dump file. Under some circumstances, Dr. Watson does not start and will cause an exception in User32.dll.

CAUSE

This behavior can occur if the program causing the exception is running as a service, but the service account does not have the right to log on locally.

Or, the service account is not part of the local administrators group.

WORKAROUND

Give the service account for the program the right to log on locally or include the service account in the local Administrators group. Additionally, after logging the account on to the console, start Dr. Watson with the -i (interactive) switch.

Modification Type:MajorLast Reviewed:10/9/2002
Keywords:kbinfo KB175875