PRB: "Access Is Denied" Error When You Expect Logon Dialog Box to Appear (175805)
The information in this article applies to:
- Microsoft Visual InterDev 1.0
This article was previously published under Q175805 SYMPTOMS
When using NT Challenge/Response authentication, individuals accessing the
site from the Internet receive "Error: Access Is Denied" when trying to
access a secure Web page or directory.
Users connecting to the site internally (via corporate LAN) and logged onto
the authorized NT Domain are granted access.
CAUSE
NT Challenge/Response (NTLM) is unable to authenticate users who do not
have a direct connection to the Internet Information Server (IIS) server.
Therefore, users coming to a site through a corporate or ISP Proxy server
will receive the "Error: Access Is Denied" message.
RESOLUTION
In order to secure the site for use from the Internet, Basic Authentication
must be turned on and NTLM should be turned off. This will allow the
individual accessing the page from the Internet the opportunity to enter a
valid NT account name and password.
STATUS
This behavior is by design.
REFERENCES
For the latest Knowledge Base articles and other support information on
Visual InterDev and Active Server Pages, see the following page on the
Microsoft Technical Support site:
Modification Type: | Major | Last Reviewed: | 5/2/2006 |
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Keywords: | kberrmsg kbprb KB175805 |
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