Microsoft Mouse Works in Windows But Does Not Respond in MS-DOS (175769)



The information in this article applies to:

  • Microsoft IntelliMouse 1.0
  • Microsoft Mouse 2.0

This article was previously published under Q175769

SYMPTOMS

The mouse may not respond in MS-DOS, although it works correctly in Microsoft Windows.

CAUSE

This behavior can occur if the mouse is connected to a serial (COM) port other than COM1 or COM2. Microsoft Mouse drivers support using only the COM1 and COM2 serial ports.

RESOLUTION

To resolve this issue, use one of the following methods:

  • Move the mouse to the COM1 or COM2 port, and make sure that the serial port is configured for the standard COM1 or COM2 port settings based on the computer manufacturer's recommendations.

    For additional information about configuring COM ports in Windows, please see the following article in the Microsoft Knowledge Base:

    123992 Basic Configurations for COM Ports in Windows 95

  • If you have a combination serial and PS/2 port mouse, connect the mouse to the PS/2 port on the computer if the port is available.

MORE INFORMATION

To determine which serial port your mouse is connected to in Windows, follow these steps:

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Modems.
  3. Click the Diagnostic tab. The Diagnostic tab displays a list of devices and the ports they are connected to. Note which port the mouse is connected to.
NOTE: If the Install New Modem wizard starts, follow these steps:

  1. Click the "Don't detect my modem, I will select it from a list" check box to select it, and then click Next.
  2. Leave the default modem selected, and then click Next.
  3. Click one of the COM ports, and then click Next.
  4. If the Location Information dialog box appears, type your area (or city) code in the "What area (or city) code are you in now" box, and then click Next.
  5. Click Finish.
  6. Click the Diagnostics tab. The Diagnostic tab displays a list of devices and the ports they are connected to. Note which port the mouse is connected to.
  7. Click the General tab.
  8. Click the modem that was installed in step 2, and then click Remove.
  9. Click Close.

Modification Type:MajorLast Reviewed:12/10/2003
Keywords:kbenv KB175769