Internet Explorer cannot open the Internet site (175722)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0, when used with:
    • the operating system: Microsoft Windows XP
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows Millennium Edition
    • the operating system: Microsoft Windows 98
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01 SP1
  • Microsoft Internet Explorer 5.01 SP2, when used with:
    • the operating system: Microsoft Windows 98
    • the operating system: Microsoft Windows 95
  • Microsoft Internet Explorer 5.0, when used with:
    • the operating system: Microsoft Windows 98
    • the operating system: Microsoft Windows 95
  • Microsoft Internet Explorer 4.01 for Windows 98 SP 1
  • Microsoft Internet Explorer 4.01 for Windows 98 SP 2
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 1
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 2

This article was previously published under Q175722

SYMPTOMS

When you start Internet Explorer, you may receive the following error message:

Internet Explorer 4.x

Internet Explorer cannot open the Internet site Web address. A connection with the server could not be established.

Internet Explorer 5

The page cannot be displayed

The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings.

Cannot find server or DNS Error

CAUSE

This error message may occur if any of the following conditions is true:
  • Multiple copies of the Wsock32.dll file are installed on your computer.
  • An incorrect version of the Wsock32.dll file is installed on your computer.
  • If you try to view a file (file://) you do not have permissions to view.
  • Intermittent connection problems, low system resources, and dropped connections while attempting to load the Web page.
  • You are using America Online as your Internet service provider, and there is not a Dial-Up Adapter installed, but there is an AOL Adapter.
  • Unable to resolve the DNS name, or the DNS server returned an error.
  • Corrupted cookies can also cause this issue with Internet Explorer 5.
  • The Internet Explorer connection settings for the dial-up connection are configured to use a proxy server.

RESOLUTION

To resolve this issue, use the appropriate method:

Verify DNS server settings

If you are receiving a DNS error, the URL of the page that you are trying to access may not be correctly associated with its current IP address. Therefore, your browser cannot connect to the page and cannot display it. Verify your DNS server settings with your network administrator or ISP, and make sure that the DNS servers are working correctly.

Note Your firewall program may be blocking your access to the Internet. Therefore, contact your Firewall program vendor to configure the settings correctly.

Rename the additional Wsock32.dll files

  1. Click Start, point to Find, and then click Files Or Folders.
  2. In the Named box, type wsock32.dll, and then click Find Now.
  3. Rename any copy of the Wsock32.dll file that is not located in the Windows\System folder. To rename a file, right-click it, type the new file name, and then press ENTER.

Replace the Wsock32.dll file

  1. Restart Windows 95, press the F8 key when you see the "Starting Windows 95" message, and then choose Safe Mode Command Prompt Only from the Startup menu. For Windows 98, restart your computer, press and hold down the CTRL key after your computer completes the Power On Self Test (POST), and then choose Safe Mode Command Prompt Only from the Startup menu.
  2. Rename the Wsock32.dll file in the Windows\System folder to Wsock32.old Note that this assumes you do not have a file named Wsock32.old. If you do have a file by this name, use a file name extension that is not currently in use.
  3. Restart Windows 95/98 normally.
  4. Extract a new copy of the Wsock32.dll file from your original Windows 95/98 CD-ROM or floppy disks into the Windows\System folder. For information about how to extract a file, please see the following article in the Microsoft Knowledge Base:

    129605 How to Extract Original Compressed Windows Files

  5. Restart your computer.

Viewing a file (file://) that you do not have permissions to view

Contact your system administrator to obtain permissions to view the appropriate file.

Connection problems, low resources, and dropped connections

If you have connection problems, or dropped connections, try again until you successfully establish a good connection. If your computer's system resources are low, close unneeded programs, or restart your computer.

Corrupted cache

If your cache is corrupted, you can delete the contents of the Cookies folder, history entries in Internet Explorer, and the Temporary Internet Files folder. However, you may lose your customizations on some Web sites. You may want to move the contents of the Cookies folder temporarily, connect to the Internet, and then move the cookies back a few at a time to determine which cookies are corrupted. For more information about how to do this, click the following article numbers to view the articles in the Microsoft Knowledge Base:

278835 How to delete cookie files

157729 How to clear the history entries in Internet Explorer

260897 How to delete the contents of the Temporary Internet Files folder

Reconfigure the proxy server settings in Internet Explorer

To reconfigure your proxy server settings:
  1. In Internet Explorer, click Internet Options on the Tools menu.
  2. Click the Connections tab.
  3. Select the dial-up connection, and then click the Settings button.
  4. Clear the Automatically detect settings and Use proxy server check boxes are not selected.

Remove the Winsock 2 update

Remove the Winsock 2 update by running the C:\Windows\Ws2bakup\Ws2bakup.bat file. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

191064 Error messages when running TCP/IP-based utilities or programs

Remove and reinstall Dial-Up Networking

For information about how to remove and reinstall Dial-Up Networking, see the following article in the Microsoft Knowledge Base:

181599 How to remove and reinstall dial-up networking and TCP/IP files

MORE INFORMATION

The Windows 95 Wsock32.dll file is 65 KB in size and has a date stamp of 7/11/95. In some versions of Windows 95 OEM Service Release 2 (OSR2), the Wsock32.dll file may have a different date stamp. The Windows 98 Wsock32.dll file is 40 KB in size and has a date stamp of 5/11/98. The Wsock32.dll file included with Windows 98 Second Edition is 40 KB in size, with a date of 4/23/99. For more information about this issue, click the following article number to view the article in the Microsoft Knowledge Base:

175039 Error message: A connection to the server could not be established

For more information about how to use the Extract tool, click Start, point to Programs, click MS-DOS prompt, type extract, and then press ENTER. Or, see the following article in the Microsoft Knowledge Base:

129605 How to extract original compressed Windows files

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

306094 Cannot view page when you use a file:// URL

265487 How Remote Storage creates media copies


Modification Type:MinorLast Reviewed:6/17/2006
Keywords:kberrmsg kbprb KB175722