Cardbus Cards May Not Work with Vesuvius Chip Set (175590)



The information in this article applies to:

  • Microsoft Windows 95 OEM Service Release 2
  • Microsoft Windows 95 OEM Service Release 2.1

This article was previously published under Q175590

SYMPTOMS

CardBus cards may not work on computer with a Vesuvius chip set.

CAUSE

The Vesuvius PCI IRQ miniport driver (Pcimp.pci) does not support the SetTrigger and GetTrigger functions that report and set level-triggered interrupts. In order for the CardBus bridge to be configured for a CardBus card's memory and I/O windows, CardBus cards require level-triggered interrupts.

RESOLUTION

To work around this problem, disable PCI Bus IRQ Steering in Device Manager. To do so, follow these steps.
  1. Click Start, point to Settings, click Control Panel, and then double- click the System icon.
  2. Click the Device Manager tab.
  3. Double-click the System Devices branch to expand it.
  4. Double-click PCI Bus, and then click the IRQ Steering tab.
  5. Click the Use IRQ Settings check box to clear it, click OK, and then click OK.
  6. Restart your computer.

STATUS

This problem no longer occurs in Windows 98. To resolve this problem, install the current version of Windows. For information about the current version of Windows, visit http://www.microsoft.com/windows.

MORE INFORMATION

For additional information about issues resolved by updates to this component, please see the following article in the Microsoft Knowledge Base:

174733 OPTi FireStar Chip Set Not Recognized by Windows 95

For additional information about Windows 95 updates, please see the following article in the Microsoft Knowledge Base:

161020 Implementing Windows 95 Updates


Modification Type:MinorLast Reviewed:9/22/2005
Keywords:kbHotfixServer kbQFE kbHardware KB175590