PRB: SQL Server May Appear to Stop Responding Upon Startup (175398)
The information in this article applies to:
This article was previously published under Q175398 SYMPTOMS
SQL Server starts successfully, but any attempt to connect to it is
unsuccessful. It appears as if the server has stopped responding.
CAUSE
The automatically executed sp_sqlregister stored procedure calls the
xp_sqlregister extended stored procedure. The DLL that contains this
extended stored procedure has additional functions that depend on Open
Database Connectivity (ODBC). If the versions of Odbcint.dll and Odbc32.dll
on the computer are different, the ODBC Driver Manager produces the
following message:
The ODBC resource DLL(C:\WINNT\System32\odbcint.dll) is a different
version than the ODBC driver manager (C:\WINNT\System32\ODBC32.dll).
You need to reinstall the ODBC components to ensure proper operation.
PRESS OK to proceed, CANCEL to abort.
The problem occurs when SQL Server is running as a service without the
"Allow Service to Interact with Desktop" check box enabled. If this is the
case, the warning dialog box described above goes to the virtual desktop,
so you never see it. Because you can't see it, you can never press OK to
continue, so it appears that the server has stopped responding.
WORKAROUND
To permanently resolve this problem, update your ODBC components so that
they all have the same file versions.
To temporarily work around this problem, do any one of the following:
- Enable trace flag 4022 (-T4022) in the startup parameters, to bypass the
startup stored procedures.
- Change the startup account to system account with the "Allow Service To
Interact With Desktop" option enabled so that you can get the warning
message and press OK to continue.
- Start SQL Server from a command prompt with the -c option.
- Replace the Odbcint.dll and odbc32.dll files with those from Windows
NT 4.0 Service Pack 3.
Modification Type: | Major | Last Reviewed: | 10/3/2003 |
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Keywords: | kbenv kbinterop kbprb KB175398 |
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