OFF97: "Accwiz.dll Unable to Register Itself" Err on Windows NT (175323)



The information in this article applies to:

  • Microsoft Office 97 Professional Edition for Windows

This article was previously published under Q175323

SYMPTOMS

Moderate: Requires basic macro, coding, and interoperability skills.

If you install Microsoft Office 97 Professional Edition on a Windows NT Workstation, and then log on to the same computer as a different user and install Office 97 again, the installation maintenance screen appears. When you click Reinstall, the Setup program copies files; however after you receive the message that Setup is updating your system, you receive the following error:
Accwiz.dll was unable to register itself in the system registry.
When you click OK, you receive the following error message:
Microsoft Office 97 Setup was not completed successfully.

CAUSE

This problem occurs when both of the following conditions are true:
  • You have installed Microsoft Office 97 Professional Edition on a computer running Microsoft Windows NT 3.51 or 4.0 after logging on as a user who is a member of the Users group, but who is not a member of the Administrators group.

  • You are reinstalling Microsoft Office 97 on the same computer after logging on as a different user who is a member of the Users group, but who is not a member of the Administrators group.

RESOLUTION

If you want more than one user to run Office 97 Professional on a Windows NT 4.0 Workstation computer, a member of the Administrators group should install it first. This allows different users to run Office programs without having to run Setup.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Office 97 Professional Edition. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

MORE INFORMATION

Steps to Reproduce Behavior

  1. Start User Manager on a computer running Microsoft Windows NT Workstation.
  2. On the User menu, click New User.
  3. In the New User dialog box, type User1 in the Username box. If the User Must Change Password At Next Logon check box is selected, click to clear it.
  4. Make sure that User1 is a member of the Users group but is not a member of the Administrators group. Then click OK.
  5. Repeat steps 3 and 4 to create the second user called User2.
  6. Log on as User1 and run Setup to install Microsoft Office 97 Professional Edition.
  7. Log on as User2 and run Setup again.
  8. When the installation maintenance screen appears, click Reinstall. Note that the Setup program copies files; however, after you receive the message that Setup is updating your system, you receive the error described in the Symptoms section.

Modification Type:MinorLast Reviewed:1/28/2005
Keywords:kbbug kberrmsg kbsetup KB175323