OL97: Outlook Caused an Invalid Page Fault in AWFXCG32.DLL (175314)
The information in this article applies to:
This article was previously published under Q175314 SYMPTOMS
When you quit Microsoft Outlook 97, you receive the error:
OUTLOOK caused an invalid page fault in module AWFXCG32.DLL at
0137:7f7ef389.
NOTE: The hexadecimal address at the end of the message may appear
differently. Also, you may get the message "Invalid Page Fault in
Kernel32.dll" instead, under the same circumstances.
CAUSE
There are three possible causes for this problem:
- Microsoft Internet Explorer version 4.0 is used in conjunction with the
Microsoft Fax service.
- Microsoft Internet Explorer version 5.0 is used in conjunction with the
Microsoft Fax service.
- The Distributed Common Object Model for Windows 95 (DCOM95) that ships
with Microsoft Visual C++ 5.0, Microsoft Visual Basic 5.0, and Microsoft
Visual Studio 97, is used in conjunction with the Microsoft Fax service.
RESOLUTION
There are six methods to resolve this problem.
- Remove DCOM95 from your computer.
- Remove Microsoft Fax from your Outlook Profile.
- Rename the Awfxcg32.dll and reinstall Internet Explorer 4.0.
- Extract the Awfxcg32.DLL.dll file from the IE 4.0 CD cab files.
- Obtain the Awfxcg32.exe file from the Microsoft Download Center.
- Click Close when you receive the error message.
Remove DCOM95 from Your Computer
To remove DCOM95 from your computer, follow these steps:
- On the Windows taskbar, click Start, point to Settings, and then click
Control Panel.
- In Control Panel, double-click Add/Remove Programs.
- Click to select "DCOM for Windows 95" and click Add/Remove.
- When prompted, click Yes to restart your computer.
Remove Microsoft Fax from Your Outlook Profile
To remove Microsoft Fax from your Outlook profile, follow these steps:
- Quit Outlook.
- On the Windows taskbar, click Start, point to Settings, and then
click Control Panel.
- Double-click Mail and Fax, click Show Profiles, select the Profile that
contains the fax service, and then click Properties.
- Click Microsoft Fax, click Remove, then click Yes.
- Click OK, then click Close.
- On the File menu, click Close.
Rename Awfxcg32.dll and Reinstall Internet Explorer 4.0
To rename Awfxcg32.dll and reinstall Internet Explorer 4.0, follow these
steps:
- Click the Start button, click Shut Down, click to select, "Restart the
computer in MS-DOS mode," and then click Yes.
- After your computer restarts, at the Command prompt, type
then press ENTER.
NOTE: If you are using Windows NT 4.0, use
- Use the MS-DOS Rename command to change the name of the file:
ren awfxcg32.dll awfxcg32.old
then press ENTER.
- At the Command prompt, type
and then press ENTER.
- At the Command prompt, type
and then press ENTER. This will start Windows and any programs in your
Startup folder.
- Run the Setup program for Internet Explorer 4.0. Click to select the
option to Reinstall All.
This procedure will install an updated version of the Awfxcg32.dll
file. The full functionality to send and receive faxes is maintained.
Extract AWFXCG32.dll from the IE 4.0 cab files
Extract a copy of the Awfxcg32.dll file from the Internet Explorer 4.0
cabinet files. To do this, follow these steps:
- Click Start, point to Programs, and then click MS-DOS Prompt.
- Type "cd\" (without quotation marks), and then press ENTER.
- Type the following line at the command prompt, and then press ENTER
extract <drive>:<path>\ie4_s2.cab ie4_2.cab /l <drive2>:<path2>
where <drive> is the drive letter in which the Internet Explorer 4.0
Setup files are located, <path> is the path to the folder in which the
Internet Explorer 4.0 Setup files are located, <drive2> is the drive in
which to extract the Ie4_2.cab file to, and <path2> is the location in
which to extract the Ie4_2.cab file to. For example:
extract c:\intern~1.0se\ie4_s2.cab ie4_2.cab /l c:\intern~1.0se
- Type the following line at the command prompt, and then press ENTER
extract <drive>:<path>\ie4_2.cab awfxcg32.dll /l <drive2>:<path2>
where <drive> is the drive letter in which the IE4_2.cab is located,
<path> is the path to the folder in which the IE4_2.cab is located,
<drive2> is the drive in which Windows is installed on, and <path2> is
the location of the Windows\System folder. For example:
extract c:\intern~1.0se\ie4_2.cab awfxcg32.dll /l c:\windows\system
- Type "exit" (without quotation marks), and then press ENTER.
- Restart your computer.
For more information about using the Extract tool, see the following
article in the Microsoft Knowledge Base:
129605 How to Extract Original Compressed Windows Files
Obtain the Awfxcg32.exe File from the Microsoft Download CenterFor additional information about how to obtain and use this file, click the article number below
to view the article in the Microsoft Knowledge Base:
174926 Updated Awfxcg32.dll to Fix IPF Exiting Outlook
Click Close When You Receive the Error Message
Because this error occurs during the shutdown phase, there is no effect on
your data.
Modification Type: | Major | Last Reviewed: | 10/26/2000 |
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Keywords: | kbprb KB175314 |
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