CACLS Quits on Access Denied Errors with /c (175048)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0

This article was previously published under Q175048

SYMPTOMS

When using CACLS to modify file access control lists (ACLs), the program terminates prematurely on Access Denied errors, even if the /c switch (instructing the program to continue on Access Denied errors) is used.

CAUSE

CACLS may be run in one of two modes: Display mode or Modify mode. The logic for continuing on Access Denied errors was only implemented for CACLS running in Display mode.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

152734 How to Obtain the Latest Windows NT 4.0 Service Pack


The hotfix adds logic for continuing on Access Denied errors in Modify mode, in addition to Display mode.

STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix KB175048