Err Msg: A Connection to the Server Could Not Be Established (175039)
The information in this article applies to:
- Microsoft Internet Explorer 2.0 for Windows NT 4.0
- Microsoft Internet Explorer 3.0 for Windows NT 4.0
- Microsoft Internet Explorer 3.01 for Windows NT 4.0
- Microsoft Internet Explorer 3.02 for Windows NT 4.0
- Microsoft Internet Explorer 4.0 for Windows NT 4.0
- Microsoft Internet Explorer 4.01 for Windows NT 4.0
- Microsoft Internet Explorer 5.0 for Windows NT 4.0
- Microsoft Internet Explorer 5.01 for Windows NT 4.0
- Microsoft Internet Explorer 5.5 for Windows NT 4.0
- Microsoft Internet Explorer 1.0 for Windows 95
- Microsoft Internet Explorer 2.0 for Windows 95
- Microsoft Internet Explorer 3.0 for Windows 95
- Microsoft Internet Explorer 3.01 for Windows 95
- Microsoft Internet Explorer 3.02 for Windows 95
- Microsoft Internet Explorer 4.0 for Windows 95
- Microsoft Internet Explorer 4.01 for Windows 95
- Microsoft Internet Explorer 5.0 for Windows 95
- Microsoft Internet Explorer 5.01 for Windows 95
- Microsoft Internet Explorer 5.5 for Windows 95
- Microsoft Internet Explorer 3.x for Windows 95
- Microsoft Internet Explorer 4.x for Windows 95
This article was previously published under Q175039 SYMPTOMS
When you try to connect to a Web site after installing Internet Explorer,
you may receive the following error message:
A connection to the server could not be established.
Even though you are unable to access the Internet, you may be able to
access an intranet Web site.
CAUSE
This error message can occur if the Wsock32n.dll file is not updated
during the Internet Explorer 4.0 installation. This can occur if you
upgrade Internet Explorer 3.02 to Internet Explorer 4.0 and you connect
to the Internet using a SOCKS proxy server.
RESOLUTION
To resolve this problem, use either of the following methods:
Upgrade to Internet Explorer 4.01
Obtain Internet Explorer 4.01. To do so, visit the following Microsoft Web
site:
Replace the Wsock32n.dll File
Extract and Replace the Wsock32n.dll File for Windows 95:
- Restart Windows 95, press the F8 key when you see the "Starting Windows
95" message, and then choose Safe Mode Command Prompt Only from the
Startup menu.
- Rename the Wsock32n.dll file in the Windows\System folder to
Wsock32n.old by typing the following line and then pressing ENTER
ren <drive>:\<windows>\system\wsock32n.dll wsock32n.old
where <drive> is the drive letter on which the Windows folder is
located, and <windows> is the name of the folder in which Windows is
installed. For example:
ren c:\windows\system\wsock32n.dll wsock32n.old
NOTE: This procedure assumes you do not have a file named Wsock32n.old.
If you do have a file by this name, use a file name extension that is
not currently in use.
- Type the following line, and then press ENTER
extract <drive>:<path>ie4_s4.cab /l <drive2>:<path2>
where <drive> is the drive letter on which the Internet Explorer 4.0
Setup files are located, <path> is the path to the folder in which the
Internet Explorer 4.0 Setup files are located, <drive2> is the drive
letter to which to extract the Ie4_4.cab file, and <path2> is the path
to the folder to which to extract the Ie4_4.cab file. For example:
extract c:\intern~1.0se\ie4_s4.cab /l c:\intern~1.0se
- Type the following line, and then press ENTER
extract <drive>:<path>wsock32n.dll /l <drive2>:\<windows>\system
where <drive> is the drive letter on which the IE4_4.cab file is
located, <path> is the path to the folder in which the IE4_4.cab file
is located, <drive2> is the drive on which Windows is installed, and
<path2> is the location of the Windows\System folder. For example:
extract c:\intern~1.0se\ie4_4.cab wsock32n.dll /l c:\windows\system
- Restart your computer.
Extract and Replace the Wsock32n.dll File for Windows NT:
- Click Start, point to Programs, and then click Command Prompt.
- At the command prompt, type the following commands, pressing ENTER
ren <drive>:\<windows>\system32\wsock32n.dll wsock32n.old
where <drive> is the drive letter on which the Windows folder is
located, and <windows> is the name of the folder in which Windows is
installed. For example:
ren c:\windows\system32\wsock32n.dll wsock32n.old
NOTE: This procedure assumes you do not have a file named Wsock32n.old.
If you do have a file by this name, use a file name extension that is
not currently in use.
- Type the following line, and then press ENTER
extract <drive>:<path>ie4nt_s4.cab /l <drive2>:<path2>
where <drive> is the drive letter on which the Internet Explorer 4.0
Setup files are located, <path> is the path to the folder in which the
Internet Explorer 4.0 Setup files are located, <drive2> is the drive
letter to which to extract the Ie4nt_4.cab file, and <path2> is the
path to the folder to which to extract the Ie4nt_4.cab file. For
example:
extract c:\intern~1.0se\ie4nt_s4.cab /l c:\intern~1.0se
- Type the following line, and then press ENTER
extract <drive>:<path>wsock32n.dll /l <drive2>:\<windows>\system32
where <drive> is the drive letter on which the IE4nt_4.cab file is
located, <path> is the path to the folder in which the IE4nt_4.cab file
is located, <drive2> is the drive on which Windows is installed, and
<path2> is the location of the Windows\System32 folder. For example:
extract c:\intern~1.0se\ie4_3.cab wsock32n.dll /l
c:\windows\system32
- Click Start, click Shut Down, click "Close all programs and
log on as a different user," and then click Yes.
STATUS
This problem is fixed in Internet Explorer 4.01.
Modification Type: | Minor | Last Reviewed: | 11/15/2005 |
---|
Keywords: | kberrmsg KB175039 |
---|
|