Message sent or received time is incorrect in Outlook Express (174989)



The information in this article applies to:

  • Microsoft Outlook Express 4.0 for Windows 95
  • Microsoft Outlook Express 4.01 for Windows 95
  • Microsoft Outlook Express 5.0 for Windows 95
  • Microsoft Outlook Express 5.01 for Windows 95
  • Microsoft Outlook Express 5.5 for Windows 95
  • Microsoft Outlook Express 4.0 for Windows NT 4.0
  • Microsoft Outlook Express 4.01 for Windows NT 4.0
  • Microsoft Outlook Express 5.0 for Windows NT 4.0
  • Microsoft Outlook Express 5.01 for Windows NT 4.0
  • Microsoft Outlook Express 5.5 for Windows NT 4.0
  • Microsoft Outlook Express 6.0 for Windows NT 4.0

This article was previously published under Q174989

SYMPTOMS

When you view the properties of an Outlook Express e-mail message, the sent time may be:
  • Later than the received time.
  • Marked with the same sent and delivered time.
  • Marked with a received time that is different than the actual time you received the message.

CAUSE

The behavior can occur if the time is not set correctly on:
  • The mail server that sent the message.
  • The mail server that received the message.
  • Both the mail server that sent the message, and the mail server that received the message.
Also, this behavior can occur if the time is not set correctly, or is set correctly but an incorrect time zone has been selected.

MORE INFORMATION

Outlook Express follows the RFC 822 specification. RFC 822 defines Internet standards for recording time zone information and defines ten alphabetic time zone labels. Time zone offsets West of Greenwich are expressed as negative numbers and time zone offsets East of Greenwich are expressed as positive numbers. Local time is calculated by the receiving server from the message header of the sending mail server. The recognized time zones are:
Time zone label      Numeric offset
GMT                  +  0:00
UT                   +  0:00
EST                  - 05:00
EDT                  - 04:00
CST                  - 06:00
CDT                  - 05:00
MST                  - 07:00
MDT                  - 06:00
PST                  - 08:00
PDT                  - 07:00
				
All other time zone offsets are expected to be numeric only, so that the time adjustment for the local time zone is correct. If an alphabetic time zone label is used, and it is not one of the RFC 822 defined labels, then the alphabetic offsets do not adjust the "local" time correctly because it does not calculate a correct adjustment from Greenwich Mean Time (GMT).

For example, if the mail server is using a time zone such as HKT +02:00 instead of a RFC 822 defined time zone label, the time is adjusted incorrectly. To correctly define the time zone label on the mail server, drop HKT from the time zone and just use "+02:00" so that the mail is time stamped properly. If the server is able to calculate the time properly for HKT +02:00, then a mail server program is calculating the time stamp with time zone labels that do not comply with the RFC 822 standard.

The Microsoft Exchange client is able to properly calculate the time from all ten time zones listed in the RFC 822, provided they follow the standard for this time zone in the SMTP header. All others must be listed in numeric form.

Servers supporting the RFC 822 environment need to be configured to use numeric GMT offsets for the correct date and time stamping of messages from around the world.

For more information about SMTP header times, please see the following article in the Microsoft Knowledge Base: For additional information about SMTP header times, click the following article number156965 to view the article156965 in the Microsoft Knowledge Base:

SMTP Header Time conflicts with Sent Time on message


Modification Type:MajorLast Reviewed:8/18/2004
Keywords:kbprb KB174989