FIX: Gendbc Produces Error Message when View is Open in Workarea (174886)
The information in this article applies to:
- Microsoft Visual FoxPro for Windows 3.0
- Microsoft Visual FoxPro for Windows 3.0b
- Microsoft Visual FoxPro for Windows 5.0
- Microsoft Visual FoxPro for Windows 5.0a
- Microsoft Visual FoxPro for Macintosh 3.0b
This article was previously published under Q174886 SYMPTOMS
Gendbc.prg produces the following error message when run against a
database:
File 'c:\Temp\nnnnnnn.tmp' does not exist.
Where n represents a series of numbers identifying the .tmp file.
CAUSE
A view is open in a workarea when Gendbc.prg is run against a database.
RESOLUTION
To avoid this error, close the Open View. Below are three ways to do this:
- Close the open view using the Data Sessions window (or the View window
in Visual FoxPro 3.0).
- Select the view and issue a USE in the
Command window.
- Issue a CLOSE TABLES ALL in the Command
window.
The last command, however, closes all open views and tables.
STATUS
Microsoft has confirmed this to be a bug in the Microsoft products listed
at the beginning of this article. This has been corrected in Visual FoxPro
6.0.
Modification Type: | Major | Last Reviewed: | 5/12/2003 |
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Keywords: | kbbug kbfix kbprb kbvfp600fix KB174886 kbAudDeveloper |
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