Windows Restarts Continuously with Blue Screen (174630)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows NT Server, Enterprise Edition 4.0
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0

This article was previously published under Q174630
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you start Windows, your computer may briefly display the blue startup screen and then continuously restart.

CAUSE

This behavior can occur if the following conditions exist:
  • A fatal system error (STOP error) causes the computer to stop.
  • The Automatically Reboot option is enabled under Recovery on the Startup/Shutdown tab in System properties.
  • The Windows paging file is smaller than the amount of physical memory installed in the computer or there is insufficient free space on the system hard disk to write the error dump file (Memory.dmp).

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

NOTE: To work around this issue, you require a parallel installation of Windows.

To make the necessary changes, follow these steps:
  1. Install Windows to a different folder.
  2. Run Regedt32.exe from the new installation of Windows, and then go to the HKEY_LOCAL_MACHINE key.
  3. On the Registry menu, click Load Hive, and then open the System file in the original Windows installation location. By default, this installation is located at %SystemRoot%\System32\Config\System.
  4. Enter an arbitrary name when you receive a prompt for a key name in the Load Hive window. This loads the original HKEY_LOCAL_MACHINE hive as a subkey of the current key.
  5. Change the value data in the AutoReboot value to 0 (zero), instead of 1, in the following key:

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CrashControl

  6. Collapse the HKEY_LOCAL_MACHINE subkey and unload the hive.
This disables the Automatically Reboot option in the original Windows installation. After you follow these steps, you may be able to gather information from the STOP error message and resolve the problem that prevents the computer from starting.

Another workaround may be necessary if the minimum size of the paging file is set to a value less than the amount of physical memory. Windows requires a paging file on the system drive large enough to hold all of physical memory, plus 1 megabyte (MB), to write debugging information. You can modify the PagingFiles value of the original installation so that the dump file can be created by the STOP error message. Enough free disk space must be available on the system drive for the paging file.

Follow these steps to change the PagingFiles value in the System file in the original Windows installation location:
  1. Follow steps 1-4 from the preceding workaround.
  2. Change the data value of the PagingFiles value to allow a minimum value of the amount of physical memory plus 1 MB, but not greater than the amount of free space on the hard disk. The key name is:

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Session Manager\Memory Management

    For example: "drive:\pagefile.sys nnnnnn" where drive is the letter of the system hard disk and nnn is a number for the minimum and maximum size of the paging file.
  3. Check the following key to verify that the CrashDumpEnabled value is set to a data value of 1:

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CrashControl

  4. Collapse the HKEY_LOCAL_MACHINE subkey and unload the hive.
  5. Attempt to start the original installation of Windows and the STOP error message should appear. The dump information is stored in the paging file.
  6. Restart the computer and select the parallel installation of Windows. This allows the dump file to be created and you may be able to use the information to resolve the problem that causes the STOP error message in the original installation.

    NOTE: The dump file is saved in the %SystemRoot%\Memory.dmp file, where %SystemRoot% is the parallel installation system folder.

MORE INFORMATION

Windows may encounter a problem during startup that results in a STOP error message. Depending on the system configuration, the blue screen may not be displayed long enough to record the error information. Using the workarounds listed above, you can alter the startup process so that important information about the STOP error message can be gathered.

For additional information about how to troubleshoot STOP error messages, click the article numbers below to view the articles in the Microsoft Knowledge Base:

123750 Debugging Windows NT Setup STOP Screens

129845 Blue Screen Preparation Before Contacting Microsoft

For additional information about a parallel install of Microsoft Small Business Server, click the article number below to view the article in the Microsoft Knowledge Base:

252777 How to Perform a Parallel Installation on Small Business Server


Modification Type:MajorLast Reviewed:8/10/2006
Keywords:kbenv kberrmsg kbprb KB174630