PRB: <USAGE VALUE="Email"> in a CDF Does Not Send E-mail (174546)
The information in this article applies to:
- Microsoft Internet Explorer (Programming) 4.0
- Microsoft Internet Explorer (Programming) 4.01
This article was previously published under Q174546 SYMPTOMS
Despite the fact that <USAGE VALUE="Email"> has been specified for a parent
ITEM element in a CDF file, the subscribed user never receives the e-mail
when a content update occurs.
CAUSE
Two things may cause this problem to occur: either the user did not
specifically ask to receive e-mail notifications for content update when he
or she subscribed to the channel, or the SMTP server was not specified
correctly.
RESOLUTION
In order for channel email notifications to get sent, all three conditions
have to be met:
- Specify <USAGE VALUE="Email"> in your CDF file, as in this example:
<CHANNEL HREF="http://example.microsoft.com"
<USAGE VALUE="Email" />
</ ITEM >
</CHANNEL>
- When subscribing to the channel, click the Customize button
and select YES when asked if you want to be notified in an e-mail
message when the page has changed. (This was added as a pre-requisite
to receiving e-mail in response to user complaints about receiving
unwanted e-mail from sites they subscribed to. Therefore, unless the
user chooses to be notified, no e-mail will be sent.)
- When prompted for an e-mail address, click the Change Address button and
specify the right SMTP server name. If you do not know, ask your ISP
(Internet Service Provider) what server name to specify.
STATUS
This behavior is by design.
REFERENCES
Internet Client SDK documentation
Modification Type: | Major | Last Reviewed: | 10/2/2003 |
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Keywords: | kbChannels kbIE400 kbie401 kbie500 kbprb KB174546 kbAudDeveloper |
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