FP98: Some FrontPage Components Do Not Work on Disk-Based Webs (173437)
The information in this article applies to:
- Microsoft FrontPage 98 for Windows
This article was previously published under Q173437 SYMPTOMS
When you browse a Hypertext Markup Language (HTML) page that contains a FrontPage component (either by clicking the Preview tab at the bottom of the FrontPage window or by clicking the
Preview In Browser button on the Standard toolbar), the following error message may appear:
This page contains elements that may need to be saved or published to
display properly.
CAUSE
FrontPage components that interact with a Web server do not function when
you create a disk-based FrontPage Web. Browse-time components only
function when you use a Hypertext Transfer Protocol (HTTP) server on which you have installed
the FrontPage 98 Server Extensions.
WORKAROUND
To work around this behavior, use the appropriate method for your situation.
Method 1: If You Are Using Components That Interact with a Web Server
Publish Active Server Pages and/or the Internet Database Connector on one of the following server
configurations:
- Microsoft Personal Web Server for Windows 95
- Peer Web Services for Microsoft Windows NT 4.0 Workstation
- Microsoft Internet Information Server for Microsoft Windows NT Server or Microsoft Windows 2000
Method 2: If You Are Using Browse-Time Components
You can turn on FrontPage browse-time components by publishing your disk-based Web to an HTTP server.
For additional information about publishing a FrontPage Web to an HTTP server, click the article number below
to view the article in the Microsoft Knowledge Base:
194093 FP98: How to Publish a FrontPage Web to the Internet, Intranet
161414 FP97: How to Publish a FrontPage Web to the Internet, Intranet
| Modification Type: | Major | Last Reviewed: | 10/5/2001 |
|---|
| Keywords: | kberrmsg kbprb KB173437 |
|---|
|