XCLN: Cannot Open Third-Party Applications Attached in Exchange (173194)
The information in this article applies to:
- Microsoft Exchange Macintosh client 4.0
- Microsoft Exchange Macintosh client 5.0
This article was previously published under Q173194 SYMPTOMS
Microsoft Exchange Macintosh clients are unable to open attachments that
require a third-party application to open them. The attachment is delivered
with a generic icon and when the user tries to open it, the user gets the
following error message:
File format cannot be read
CAUSE
The file type needs to be defined on the Macintosh workstation whether the
workstation belongs to the sender or to the recipient.
RESOLUTION
To resolve this problem, you need to modify the appropriate file
associations in the Exchange Preferences file.
NOTE: To do any of the following, you need a third-party Macintosh
application called ResEdit.
Before attempting the following change, you must know the appropriate file
extension, creator, and type. To get this information, start ResEdit, and on
the File Menu, click Get File/Folder Info, and select one of the files in
question.
- Make a backup copy of the Exchange Preferences file. In the System
folder, click the Preferences folder, and click the Exchange Preferences
file icon. From the File menu, click Duplicate. This is just a
precautionary measure in case using ResEdit causes a problem with your
Preferences file.
- If it's not already running, start ResEdit.
- Open the Exchange Preferences file.
- Open the STR # section.
- Double-click Mac File Types.
- For every file type, there should be a string entry. To modify a file
association, simply select the file association you want to edit. To
enter a new string, on the Resource menu, click Insert New Field. Use
the format:
- After the appropriate information has been entered, save the file.
- When the Exchange Macintosh client is started, the edited or new file
association is available.
WORKAROUND
To successfully open an attachment that has a generic icon:
- Save the attached file to the hard disk drive.
- Start the application.
- Open the file.
| Modification Type: | Minor | Last Reviewed: | 4/21/2005 |
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| Keywords: | kbprb KB173194 |
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