Client TTLs Decremented by Two Minutes on Each Ils.modify (172932)



The information in this article applies to:

  • Microsoft Site Server 2.0
  • Microsoft Commercial Internet System 1.0

This article was previously published under Q172932

SYMPTOMS

An Internet Locator Server (ILS) client Time to Live (TTL) value is decremented by two minutes on each ILS modify.

CAUSE

The client TTL is not being reset in the correct place in the code. This causes an incorrect client TTL value to be returned. The incorrect value is always two minutes less than the current client TTL, due to some internal adjustments to deal with latency problems and because the TTL is not reset in the right place in the code. After each modify request, refresh the client TTL so that it will match the server TTL.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Site Server version 2.0.

This problem has been corrected in the latest U.S. Service Pack for Microsoft Site Server version 2.0. For information on obtaining the service pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

S E R V P A C K

Microsoft has confirmed this to be a problem in Microsoft Commercial Internet System version 1.0.

A supported fix is now available, but is not fully regression-tested and should be applied only to systems experiencing this specific problem. Unless you are severely impacted by this specific problem, Microsoft recommends that you wait for the next Service Pack that contains this fix. Contact Microsoft Product Support Services for more information.

Modification Type:MajorLast Reviewed:10/28/2003
Keywords:kbbug kbfix kbQFE KB172932