TimeServ Uses 100% of System Resources (172831)
The information in this article applies to:
- MSPRESS Microsoft Windows NT Resource Kit 3.51
- MSPRESS Microsoft Windows NT Server 4.0 Resource Kit ISBN 1-57231-344-7
- MSPRESS Microsoft Windows NT Workstation 4.0 Resource Kit ISBN 1-57231-343-9
- MSPRESS Microsoft Windows NT Server 4.0 Resource Kit, Supplement One ISBN 1-57231-559-8
- MSPRESS Microsoft Windows NT Server 4.0 Resource Kit, Supplement Two ISBN 1-57231-626-8
This article was previously published under Q172831 SYMPTOMS
Between 5 and 6 P.M. eastern time on August 13, 1997, the TimeServ
service may have begun consuming 100 percent of your system's
resources.
CAUSE
This problem appears to be caused by a change in the United States
Naval Observatory's time server. At this time, the problem does not
appear to be caused by an error in the TimeServ utility, or by a
malicious attack.
WORKAROUND
Change the TimeServ.ini file to use a Simple Network Time Protocol
Server instead of a TCP/IP Server by using the following steps.
NOTE: These steps will not work correctly if you are behind a firewall
that passes TCP but not UDP (datagrams).
- Using the Services applet in the Control Panel, stop the TimeServ
service.
- Open the \%SystemRoot%\TimeServ.ini using a simple text editor such
as Notepad.
- Click Search, and then click Find. Search for the following line:
- Insert a semicolon (;) in front of the line TYPE=INTERNET if there
is no semicolon present.
- Click Search, and then click Find. Search for the following line:
- If there is a semicolon in front of the line TYPE=NTP, delete it.
- Click Search, and then click Find. Search for the following line:
- Change the line to read as follows:
NTPServer=tick.usno.navy.mil
NOTE: You may also substitute another NTP server, such as
tock.usno.navy.mil.
- Save your changes and close Notepad.
- Click Start, point to Programs, and then click Command Prompt.
- Type timeserv -update, press ENTER, and
then close the Command Prompt window.
- Restart the TimeServ service.
STATUS
Microsoft has confirmed this to be a problem in the Microsoft products
listed at the beginning of this article. We are researching this
problem and will post new information here in the Microsoft Knowledge
Base as it becomes available.
Modification Type: | Major | Last Reviewed: | 3/8/2001 |
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Keywords: | kbprb KB172831 |
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