SNATRACE Unable to Purge Trace Files on Remote System (172817)



The information in this article applies to:

  • Microsoft SNA Server 3.0
  • Microsoft SNA Server 3.0 SP1

This article was previously published under Q172817

SYMPTOMS

The SNATRACE utility is unable to purge trace files on a remote system when you select Purge All Trace Files.

CAUSE

SNATRACE uses the RegNotifyChangeKeyValue to purge trace files. This does not work on remote systems.

STATUS

Microsoft has confirmed this to be a problem in SNA Server version 3.0 and 3.0 Service Pack 1 (SP1). This problem was corrected in the latest SNA Server version 3.0 U.S. Service Pack. For information on obtaining this Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

S E R V P A C K

MORE INFORMATION

With the fix applied, SNATRACE.EXE uses the SnaServ share point and the WaitForMultipleObjects timeout to purge files on remote systems. A Retry dialog box has also been added in case of a sharing violation.

Modification Type:MajorLast Reviewed:6/24/2004
Keywords:kbbug kbfix KB172817