OLEXP: IPF in Msimnui.dll After Upgrading Earlier version of Internet Explorer (172517)
The information in this article applies to:
- Microsoft Outlook Express 4.0 for Windows NT 4.0
- Microsoft Outlook Express 4.0 for Windows 95
This article was previously published under Q172517 SYMPTOMS
If you install the Minimal Installation version of Microsoft Internet
Explorer 4.0 on a computer on which an earlier version of Outlook Express
is installed, you may receive the following error message when you attempt
to start Outlook Express:
This program has performed an illegal operation and will be shut down.
If the problem persists, contact the program vendor.
When you click Details, the following details are displayed:
MSIMN caused an invalid page fault in module MSIMNUI.DLL at <address>.
When you click Close, Outlook Express quits.
CAUSE
The Msimnui.dll file installed by Outlook Express is not compatible with
the newer version of the Comctl32.dll file installed by Internet Explorer
4.0.
RESOLUTION
To resolve this issue, use the appropriate method:
Method 1
Reinstall Outlook Express from the Internet Explorer 4.0 Component
Download Web page by following these steps:
- In Control Panel, double-click Add/Remove Programs.
- Click the Install/Uninstall tab, click Microsoft Internet Explorer 4.0
in the list of installed programs, and then click Add/Remove.
- Click "Add a component to Internet Explorer," and then click OK.
- Click Yes when you receive the following prompt:
Active Setup is about to determine what internet components are installed on your computer. Is this OK?
- Click the Microsoft Outlook Express check box to select it, and then
click Yes when you receive the following prompt:
Microsoft Outlook Express is already installed. Do you want to
reinstall this component?
- Click Next, click a download site in the list, and then click Install
Now to download and install Outlook Express.
Method 2
Rename the *.idx, *.mbx, and *.nch files for each folder in Outlook
Express, and then start Outlook Express. To do so, follow these steps:
- Click Start, point to Find, and then click Files Or Folders.
- In the Named box, type "*.idx" (without quotation marks), and then
click Find Now.
- Right-click each file one at a time, and then click Rename.
- Type "<filename>.idd" (without quotation marks), where <filename> is
the original file name, and then press ENTER. For example, if you are
renaming the Inbox.idx file, type "inbox.idd" (without quotation
marks), and then press ENTER.
- Repeat steps 3-4 for each file.
- In the Named box, type "*.mbx" (without quotation marks), and then
click Find Now.
- Right-click each file one at a time, and then click Rename.
- Type "<filename>.mbd" (without quotation marks), where <filename> is
the original file name, and then press ENTER. For example, if you are
renaming the Inbox.mbx file, type "inbox.mbd" (without quotation
marks), and then press ENTER.
- Repeat steps 7-8 for each file.
- In the Named box, type "folders.nch" (without quotation marks), and
then click Find Now.
- Click the Folders.nch file, click Rename, type "folders.ncc" (without
quotation marks), and then press ENTER.
- Quit the Find Files Or Folders tool.
- Start Outlook Express. When you start Outlook Express, the default
folders are re-created.
NOTE: Custom folders are not re-created when you start Outlook Express. For
information about creating custom folders, click Content And Index on the
Help menu in Outlook Express, click the Index tab, type "folders, adding"
(without quotation marks), and then click Display.
If you can successfully start Outlook Express, you can test to see whether
a <filename>.mbx file that you renamed in step 8 is damaged. To do so,
follow these steps:
- Quit Outlook Express.
- Rename the current <filename>.idx file to <filename>.ddd and the
corresponding <filename>.mbx file to <filename>.bbb.
- Rename the original <filename>.mbd file to <filename>.mbx.
NOTE: The <filename>.idx file for a <filename>.mbx file is re-created
when you Start Outlook Express.
- Start Outlook Express. If you can successfully start Outlook Express,
repeat test steps 1-4 for another <filename>.mbx file. If you are unable
to successfully start Outlook Express, the <filename>.mbx file may be
damaged. Do not use the original <filename>.mbx file. Rename the
original <filename>.mbx file back to <filename>.mbd, and rename the
<filename>.idx file to <filename>.dd2.
NOTE: The <filename>.idx and <filename>.mbx files are again re-created when
you start Outlook Express.
Method 3
WARNING: Using Registry Editor incorrectly can cause serious problems that
may require you to reinstall your operating system. Microsoft cannot
guarantee that problems resulting from the incorrect use of Registry Editor
can be solved. Use Registry Editor at your own risk.
For information about how to edit the registry, view the "Changing Keys And
Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete
Information in the Registry" and "Edit Registry Data" Help topics in
Regedt32.exe. Note that you should back up the registry before you edit it.
Delete the following registry key(s):
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Outlook Express
HKEY_CURRENT_USER\Software\Microsoft\Outlook Express
STATUSMORE INFORMATIONSteps to Reproduce the Behavior
Modification Type: | Major | Last Reviewed: | 11/4/2003 |
---|
Keywords: | kberrmsg kbprb kbsetup KB172517 |
---|
|