Add Printer Wizard Stops Responding (Hangs) When Searching for Remote Printers (172147)
The information in this article applies to:
- Microsoft Windows NT Server 4.0 Terminal Server Edition
- Microsoft Windows NT Workstation 3.51
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows NT Server 3.51
- Microsoft Windows NT Server 4.0
This article was previously published under Q172147 SYMPTOMS
When you attempt to browse for printers using the Add Printer Wizard and
selecting Network Printer Server and choosing Next, the Connect to Printer
dialog box may stop responding (hang). The status displays "Working..." but
control never returns to the user.
CAUSE
The above symptom may occur for one of the following reasons:
- Creation of null printer shares on the print server
NullSessionShares can be added for Downlevel print clients who may not
have an account or because of a conflicting account. For more
information on NullSessionShares, please see the following Microsoft
Knowledge Base article:
121853 Downlevel Print Jobs Not Redirected Correctly
- Domain names containing a comma (,) in the first character position.
RESOLUTION
Winspool.drv has been redesigned to take these queues into account when
browsing the domain for printers.
To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack
STATUSMicrosoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.
Modification Type: | Minor | Last Reviewed: | 9/23/2005 |
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Keywords: | kbHotfixServer kbQFE kbbug kbfix kbprint KB172147 |
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