System Agent Does Not Function After Uninstalling Task Scheduler (172080)



The information in this article applies to:

  • Microsoft Internet Explorer 1.0 for Windows 95
  • Microsoft Internet Explorer 2.0 for Windows 95
  • Microsoft Internet Explorer 3.0 for Windows 95
  • Microsoft Internet Explorer 3.01 for Windows 95
  • Microsoft Internet Explorer 3.02 for Windows 95
  • Microsoft Internet Explorer 4.0 for Windows 95
  • Microsoft Internet Explorer 4.01 for Windows 95
  • Microsoft Internet Explorer 5.0 for Windows 95
  • Microsoft Internet Explorer 5.01 for Windows 95
  • Microsoft Internet Explorer 5.5 for Windows 95
  • Microsoft Internet Explorer 3.x for Windows 95
  • Microsoft Internet Explorer 4.x for Windows 95

This article was previously published under Q172080

SYMPTOMS

After you uninstall Task Scheduler, the System Agent icon does not appear on the taskbar. If you attempt to start System Agent by using the Start menu, you may receive the following error message:
Cannot restart System Agent, reinstall MS Plus
In addition, when you start Windows 95, you may receive the following error message:
Essential file is missing on bootup
Sage.vxd

CAUSE

This behavior can occur if you uninstall Task Scheduler. Task Scheduler replaces System Agent, but System Agent is not restored when you uninstall Task Scheduler.

RESOLUTION

To resolve this issue, reinstall System Agent. For information about reinstalling System Agent, please see the following article in the Microsoft Knowledge Base:

133191 Reinstalling System Agent Without Losing Scheduled Tasks

MORE INFORMATION

Task Scheduler is an Internet Explorer component that you can install using the Add/Remove Programs tool in Control Panel after Internet Explorer is installed.

For information about how to add or remove Internet Explorer components, see the following article in the Microsoft Knowledge Base:

171229 How to Add and Remove Internet Explorer Components


Modification Type:MajorLast Reviewed:12/16/2003
Keywords:kberrmsg KB172080