Local Network Access Fails Or Is Slow After PPTP Connection (171922)
The information in this article applies to:
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows NT Server 4.0
This article was previously published under Q171922 SYMPTOMS
You may experience slow connections and performance or even loss of
connectivity on your local area network (LAN) after you have made a Point-to-Point Tunneling Protocol (PPTP) connection to a Windows PPTP
server.
CAUSE
Windows PPTP clients add an incorrect local subnet route to their
route tables when they connect to a PPTP server that is using the same IP
network ID.
For example, the client and the server are both on LAN subnets of a class
B address such as 172.16.0.0, using a 255.255.255.0 subnet mask. The
server is on the 172.16.1.0 subnet and the client is on the 172.16.2.0
subnet. When the client connects through PPTP, it adds a route to the
172.16.0.0 network with a gateway of the PPTP server to its route table,
which increases the time it takes to locate LAN resources.
NOTE: If the PPTP server has no route to the PPTP client's subnet, the
client will not be able to connect to its local subnet.
RESOLUTION
To work around this issue, use the following steps:
- Disable Use Default Gateway on Remote Network for the phone book entry
that you use to dial the PPTP server.
NOTE: If Use Default Gateway on Remote Network is not checked, the bad
local subnet route is not added.
- Delete the existing default gateway (if one exists) by typing the
following at a command prompt:
- Dial your PPTP phone book entry to make the connection to your PPTP
server.
- Add a new default gateway to the PPTP network by typing the following
at a command prompt:
Route add 0.0.0.0 mask 0.0.0.0 X.X.X.X
Where X.X.X.X is your client's IP address assigned by the PPTP server.
- After you disconnect, re-add your local default gateway by typing the
following command at a command prompt:
Route add 0.0.0.0 mask 0.0.0.0 Y.Y.Y.Y
Where Y.Y.Y.Y is the IP address of the default gateway, or router, on
your LAN.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. We
are researching this problem and will post new information here in the
Microsoft Knowledge Base as it becomes available.
REFERENCES
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
254231
Change in Remote Access Route Behavior with Windows 2000
Modification Type: | Major | Last Reviewed: | 7/22/2003 |
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Keywords: | kbbug kbnetwork KB171922 |
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