Restoring a User Profile On a Windows NT Workstation or Server (171769)
The information in this article applies to:
- Microsoft Windows NT Workstation 3.51
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows NT Server 3.51
- Microsoft Windows NT Server 4.0
This article was previously published under Q171769 SYMPTOMS
After you run the repair process in Windows NT and select the options below
on the restore registry screen, all default settings are restored. No user
accounts exist, and the administrator password is returned to the password
in use at the time the Emergency Repair Disk (ERD) was made or updated.
[X] SYSTEM (System Configuration)
[X] SOFTWARE (Software Information)
[X] DEFAULT (Default User Profile)
[X] SECURITY (Security Policy) and SAM (User Accounts Database)
CAUSE
Choosing to overwrite the registry and replace all SAM and security
information creates this situation.
RESOLUTION
The recommended method to restore the proper user account database and
domain password is to restore the registry from a current tape backup. If
a current tape backup is not available, or, restoring from tape will cause
other problems, the following method can be used to restore users. If using
this method causes other problems, restore the registry from backup or
recreate the user accounts.
This resolution assumes that you have the administrator password needed to
sign on to the local computer and that the user is local, or their profile
is stored locally (or the user is on the domain but their profile is stored
locally).
NOTE: This is not a feasible solution for restoring more than a few users.
This resolution does not insure that applications will function correctly.
Some applications replace Windows NT files and can not work with the
Windows NT files that are restored from the selected options through the
ERD process. Applications may need to be reinstalled.
If the User Logs On to the Computer Locally- Log on to the local computer with administrator privileges.
- Recreate the user of the workstation in User Manager.
- Go to the %SystemRoot%\Profiles\ directory and rename the Default User
profile to Default Old.
- Rename the user profile of the user you are trying to restore, Default
User.
- Log on to the local computer as that user and the Default profile will
be assigned to them.
- Log off the computer as the user, log on to the computer as
administrator, and delete the Default User profile.
- Repeat steps 1-6 to restore user's profiles.
- Rename Default Old to Default User.
If the User Logs On to the Domain but the Profile is Stored Locally- Delete the machine account from the domain.
- Log on to the local computer with administrator privileges and rejoin
the domain.
- Perform steps 3-8 above.
If the User has Successfully Logged On to the
Computer at Least Once and Created a New Profile- Log on to the local computer with administrator privileges.
- Go to the %SystemRoot%\Profiles directory, and delete the user.000
profile.
- Perform steps 3-8 above.
For more information regarding Security IDs and the ERD, refer to the
following Microsoft Knowledge Base articles
162001 Do Not Disk Duplicate Installed Versions of Windows NT
150919 How to Prevent a User from Changing the User Profile Type
122857 RDISK /S and RDISK /S- Options in Windows NT
126464 Repair Disk Utility Does Not Update SAM and Security
129037 Windows NT 3.5x and 4.0 Emergency Repair Process Screens
Modification Type: | Major | Last Reviewed: | 8/9/2001 |
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Keywords: | kbprb kbsetup KB171769 |
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