OL97: Find Items Fails When User Field Matches Built-in Field (171462)



The information in this article applies to:

  • Microsoft Outlook 97

This article was previously published under Q171462

SYMPTOMS

If you create a Messaging Application Programming Interface (MAPI) form that contains a field with the same name as one of the default fields in Outlook, the Find Items feature in Outlook may not find any items that meet your search criteria.

CAUSE

The Find Items feature in Outlook only looks at a field's name, instead of looking at the field's Set ID. Under normal circumstances, forms created in Outlook do not have this problem because Outlook will not let you add a user-defined field with the same name as an Outlook field.

MORE INFORMATION

By using an application other than Outlook, it is possible to create a MAPI form that contains a field with the same name as one of the default fields in Outlook. With the Find Items feature in Outlook, you are able to find items based on your MAPI form. If you try to search on a field with the same name as one of the default fields in Outlook, the search results will be empty.

Modification Type:MajorLast Reviewed:1/15/2000
Keywords:kbprb KB171462