Proxy Auto Dial Never Hangs Up When Idle (171360)



The information in this article applies to:

  • Microsoft Proxy Server 1.0
  • Microsoft Proxy Server 2.0

This article was previously published under Q171360

SYMPTOMS

Microsoft Proxy AutoDial does not hang up when the connection is idle.

CAUSE

The Auto-HangUp will fail with any of the following conditions:

  • You have a Winsock application on a client open and connected to the Internet.
  • You have a Web Proxy client (Web Browser) connected to a Web Page that has a refresh tag in it.
  • The active caching of the Web Proxy Service is updating the cache.
  • Other TCP/IP traffic is hitting the modem connection from the Internet.

WORKAROUND

The Idle TimeOut option in Dial Up Networking must be set for the connection to hang up after being idle.

  1. Open the Dial Up Networking dialog box, and select User Preferences from the More button.
  2. Disable AutoDial by Location and set Idle Seconds Before Hanging Up to the desired amount of time.
  3. Choose Logon Preferences from the More button and set Idle Seconds Before Hanging Up to the same value as User Preferences.
  4. Open Control Panel, Services and disable the Remote Access AutoDial Manager service.

Modification Type:MajorLast Reviewed:8/10/1999
Keywords:kbprb KB171360