Microsoft Membership Agent May Not Start (171331)
The information in this article applies to:
- Microsoft Commercial Internet System 1.0
This article was previously published under Q171331 SYMPTOMS
Microsoft Membership Agent may not start and may return the following
error messages in the Event Viewer logs.
In the system log you will get the following error message:
Event ID: 7023
Source: Sevice Control Manager
Description: The Membership Agent service terminated with the following
error:
The service has not been started.
In the application log you will get the following error messages:
Event ID: 4123
Source: Sicily
Description: Initializing buffers and connection to Membership Backend
SQL Server failed.
Event ID: 12297
Source: AccessCtl
Description: Cannot update the plans list.
If you started the Membership Agent from the command prompt, you will also
get the following error message:
The service terminated with the service specific error message:
Could not start Membership Agent service on <server name> error 1062.
CAUSE
The problem occurs because the group_limited_access_plan is in a state in
which the count of the entries in group_limited_access_plan does not match
the number of rows returned by the query:
"select t.c_group_description, p.i_group_id, i_account_id, i_owner_id
from group_limited_access_plan p, group_type t
where p.i_group_id = t.i_group_id order by p.i_group_id ".
This situation should never occur through the use of the administrative
tools that ship with Microsoft Membership Server.
RESOLUTION
To resolve this problem, make the following changes to the stored procedure
"sp_enum_access_plans":
Change
"select count(*) from group_limited_access_plan"
to
"select count(*) from group_limited_access_plan p, group_type t
where p.i_group_id = t.i_group_id"
Modification Type: | Major | Last Reviewed: | 9/30/2003 |
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Keywords: | kbusage KB171331 |
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