How to Disable SAP Broadcast for RPC Service (171307)
The information in this article applies to:
- Microsoft Windows NT Server 4.0 Terminal Server Edition
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows NT Server 4.0
This article was previously published under Q171307 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
On a computer running Windows NT Server, if Gateway Services for NetWare
(GSNW) is installed, a SAP Type 640 broadcasts every 60 seconds by the
remote procedure call (RPC) service. This SAP broadcast continues even
if the user disables the GSNW and the SAP Agent Service.
On a computer running Windows NT Workstation, the RPC service does the
SAP broadcast if the Client Services for NetWare (CSNW) and the SAP Agent
service are installed. This SAP broadcast continues even if the user
disables the SAP agent.
CAUSE
By default, the RPC service checks for the presence of Gateway
Services for NetWare and the SAP Agent service on the computer running
Windows NT Server.
On the computer running Windows NT Workstation with CSNW, the RPC service
checks for the SAP Agent service. If the services are present, RPC starts
its own thread that does the SAP broadcast Type 640 every minute.
RESOLUTIONWindows NT Server 4.0, Terminal Server EditionTo resolve this problem, obtain the latest service pack for Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack
Windows NT Server or Workstation 4.0
To resolve this problem, obtain the latest service pack for Windows NT 4.0 or
the individual software update. For information on obtaining the
latest service pack, please go to:
For information on obtaining the individual software update, contact Microsoft
Product Support Services. For a complete list of Microsoft Product Support
Services phone numbers and information on support costs, please go to the
following address on the World Wide Web:
STATUSWindows NT Server 4.0, Terminal Server EditionMicrosoft has confirmed that this is a problem in Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT Server 4.0, Terminal Server Edition Service Pack 6.Windows NT 4.0Microsoft has confirmed that this is a problem in Windows NT 4.0. This problem was first corrected in Windows NT 4.0 Service Pack 5.
Modification Type: | Minor | Last Reviewed: | 9/23/2005 |
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Keywords: | kbHotfixServer kbQFE kbfix kbother kbprb KB171307 |
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