OLEXP: "Attempt to Allocate Memory Failed" Error Message (171276)



The information in this article applies to:

  • Microsoft Outlook Express 4.0 for Windows NT 4.0
  • Microsoft Outlook Express 4.0 for Windows 95
  • the operating system: Microsoft Windows 98

This article was previously published under Q171276

SYMPTOMS

When you attempt to download your e-mail messages in Outlook Express, you may receive one of the following error messages:

  • An attempt to allocate memory failed. The system is out of memory.
  • An unknown error has occurred while attempting to receive mail. Please check your account settings, net connection, and TCP/IP configuration.

CAUSE

This behavior can occur if there is not enough free disk space to download your e-mail messages.

RESOLUTION

To resolve this issue, remove unnecessary files to increase the amount of free space on your hard disk, and then perform routine maintenance on your hard drive. To perform routine maintenance:
  1. Click Start, point to Programs, point to Accessories, point to System Tools, and then click Disk Cleanup.
  2. Select the drive on which Outlook Express installed, and then click OK.
  3. To remove unnecessary files from your hard disk follow the instructions on the computer screen.
  4. After you finish removing the files that you want to remove, run Scan Disk:
    1. Click Start, point to Programs, point to Accessories, point to System Tools, and then click Scan Disk.
    2. Under Type of test, click Standard, and then click Start.

      NOTE:If you can leave your computer running for several hours (such as overnight), click the Through option.
    3. After you finish running Scan Disk, click Close.
    4. Click Start, point to Programs, point to Accessories, point to System Tools, and then click Disk Defragmenter.
    5. In the Which drive do you want to defragment check box, click the drive on which Outlook Express is installed, and then click OK.
    6. When the defragmentation process is finished, close the Disk Defragmenter dialog box.
  5. Restart your computer.
  6. Try to download your e-mail messages
Because Windows 95 does not include Disk Cleanup, you must manually check your hard drive for unnecessary files, such as any files in your C:\Temp directory.

Modification Type:MajorLast Reviewed:11/14/2003
Keywords:kbprb KB171276