ADT/ODE: Transporter and Synchronizer Can't Share Log File (170551)
The information in this article applies to:
- Microsoft Office 97 Developer Edition
- Microsoft Access Developer's Toolkit 7.0
This article was previously published under Q170551 Advanced: Requires expert coding, interoperability, and multiuser skills.
SYMPTOMS
When you start Microsoft Replication Manager, you may receive the following
error message:
Sharing Violation while attempting to open log file <path to log file> in Deny Write mode.
This is followed by the following error, depending on which version you are
using.
In Microsoft Replication Manager 3.5
Microsoft Replication Manager can't start the Synchronizer. Without
the Synchronizer running, no synchronization of data can occur.
Do you want to work without the Synchronizer?
Synchronizer could not be initialized.
In Microsoft Replication Manager 3.0
Microsoft Replication Manager can't start the Transporter. Without
the Transporter running, no synchronization of data can occur.
Do you want to work without the Transporter?
Transport could not be initialized.
CAUSE
You are trying to run Transporter and Synchronizer at the same time,
and both are configured to use the same log file.
RESOLUTION
Reconfigure either Transporter or Synchronizer to use a different log file.
STATUS
Microsoft has confirmed this to be a problem in Microsoft Access
Developer's Toolkit 7.0 and Microsoft Office 97 Developer Edition Tools.
REFERENCES
For more information about the Synchronizer log file, search the Microsoft
Replication Manager Help Index for "log, Synchronizer."
Modification Type: | Major | Last Reviewed: | 10/20/2003 |
---|
Keywords: | kbbug kbother KB170551 |
---|
|