XADM: Error Applying Service Pack (170398)



The information in this article applies to:

  • Microsoft Exchange Server 4.0
  • Microsoft Exchange Server 5.0

This article was previously published under Q170398

SYMPTOMS

When you run the Updat.exe program to apply a service pack, the following error message occurs:
Could not open the file named C:\setup\bin\Address.dll

CAUSE

The self-extracting executable for the service pack (downloaded from the Microsoft FTP site), has been expanded without using the -d switch.

WORKAROUND

If the -d option is not used when extracting the service pack files, all the service pack files are extracted into the current working directory. Most likely, the extraction process will display messages asking the user whether certain files need to be overwritten.

If the -d option is used during the service pack expansion, it will automatically create the required directories and copy files into these directories, and no files will need to be overwritten. Therefore, to work around the problem, you need to use the -d option during the service pack expansion.

Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbprb KB170398