PRB: Error 80010010 in the NT Application Log on DAPIStart (169552)



The information in this article applies to:

  • Microsoft Exchange Development Kit (EDK)
  • Microsoft Exchange Server 4.0
  • Microsoft Exchange Server 5.0

This article was previously published under Q169552

SYMPTOMS

When using DAPI on a computer that has not had the Exchange Admin program installed on it, the error 80010010 or 80001010 may occur. The error is written to the Windows NT Application Log and is generated on the DAPIStart method.

CAUSE

The error occurs because there are components that are required to run DAPI and one of these is missing.

RESOLUTION

The items that are required to run DAPI must be setup on the computer. For more information on the required components for DAPI, please refer to the following article in the Microsoft Knowledge Base:

169551 INFO: Items Required to Use DAPI

STATUS

This behavior is by design.

MORE INFORMATION

DAPI is a DAPI supplied with Exchange that allows reading and writing to the Exchange Directory. It is typically used to create and delete mailboxes and for directory synchronization.

Modification Type:MinorLast Reviewed:3/7/2005
Keywords:kbAPI kberrmsg kbFAQ kbMsg kbprb KB169552